Bug 982489 - backport patch 'memcg: don't initialize kmem-cache destroying work for root caches'
backport patch 'memcg: don't initialize kmem-cache destroying work for root c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
All Linux
high Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 03:32 EDT by Igor Gnatenko
Modified: 2013-10-08 13:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 13:05:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2013-07-09 03:32:56 EDT
Description of problem:
I have problem with vzctl in quickly suspend and restore (kernel panic) . This patch fix my problem.
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/mm/memcontrol.c?id=f101a9464bfbda42730b54a66f926d75ed2cd31e
memcg: don't initialize kmem-cache destroying work for root caches

How reproducible:
always

Steps to Reproduce:
1. vzctl create 101 --ostemplate=centos-6-x86_64
2. vzctl start 101
3. vzctl enter 101
4. killall udevd
5. logout
6. vzctl suspend 101
7. vzctl restore
8. Quickly goto 6

Actual results:
kernel panic

Expected results:
all works fine
Comment 1 Josh Boyer 2013-09-18 16:55:43 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 2 Josh Boyer 2013-10-08 13:05:03 EDT
This was fixed with 3.10.

Note You need to log in before you can comment on or make changes to this bug.