Bug 982534 - TUI: Clean DNS server 1/2 failed
TUI: Clean DNS server 1/2 failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks: 1038370
  Show dependency treegraph
 
Reported: 2013-07-09 05:04 EDT by haiyang,dong
Modified: 2014-01-21 14:45 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
Previously it could happen that servers which were removed in the TUI didn't get removed in the actual config files. This is now fixed by removing all existing servers and writing the new ones.
Story Points: ---
Clone Of:
: 1038370 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:45:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19120 None None None Never

  None (edit)
Description haiyang,dong 2013-07-09 05:04:40 EDT
Description of problem:
Configure network with dhcp, then check the DNS server1/2 info in TUI:
DNS Server 1: 10.66.127.17
DNS Server 2: 10.66.5.26
Then delete the DNS Server 1 configuration and check the network page again
DNS Server 1: 10.66.5.26
DNS Server 2: 10.66.5.26

this result isn't what we expect result. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1716.el6
ovirt-node-3.0.0-2.999.20130708020233git0792892.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Configure network with dhcp, then check the DNS server1/2 info in TUI:
2.delete the DNS Server 1 configuration and check the network page again

Actual result:
After step 2, check the DNS server1/2 info in network page:
DNS Server 1: 10.66.5.26
DNS Server 2: 10.66.5.26                                                 

Expect result:
After step 2, the DNS server 1 with info "10.66.5.26" and the DNS server 2 is blank
DNS Server 1: 10.66.5.26
DNS Server 2: ____________

Additional info:
Comment 2 Fabian Deutsch 2013-07-19 06:22:15 EDT
A unittests should probably added for this.
Comment 3 Fabian Deutsch 2013-09-11 07:18:18 EDT
Tested as follows:

1. Apply patch
2. Enter network page
3. Enter dns servers: 192.168.122.1 and 192.168.122.2
4. <Save>
Both servers can be found in /etc/resolv.conf and /etc/default ovirt

5. Remove first dns server 192.168.122.1
6. <Save>
Only the second server can be found in /etc/resolv.conf and /etc/default ovirt

7. Remove the second (but now displayed as first) dns server 192.168.122.2
8. <Save>
No dns server is displayed, and not dns server is in /etc/resolv.conf and /etc/default/ovirt

9. Set dns server 1 to: 192.168.122.1
10. <Save>
DNS server appears in resolv.conf, defaults/ovirt and tui
Comment 6 haiyang,dong 2013-10-22 04:48:22 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Tested as follows:
1. Enter network page
2. Enter dns servers: 10.66.127.17 and 10.68.5.26
3. <Save>
Both servers can be found in /etc/resolv.conf and /etc/default ovirt

4. Remove first dns server 10.66.127.17 
5. <Save>
Only the second server can be found in /etc/resolv.conf and /etc/default ovirt

6. Remove the second (but now displayed as first) dns server 10.68.5.26
7. <Save>
No dns server is displayed, and not dns server is in /etc/resolv.conf and /etc/default/ovirt

8. Set dns server 1 to: 10.66.11.23
9. <Save>
DNS server appears in resolv.conf, defaults/ovirt and tui

so this bug has been fixed, change the status into "VERIFIED".
Comment 9 Cheryn Tan 2013-11-07 19:37:00 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 errata-xmlrpc 2014-01-21 14:45:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.