Bug 982535 - GMP native library not included in the server stack image
GMP native library not included in the server stack image
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All All
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 05:04 EDT by boussac
Modified: 2015-05-14 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description boussac 2013-07-09 05:04:48 EDT
Description of problem: 
When trying to deploy (git push) a Ruby on Rails app with the GMP gem, the production environment fails to bundle the gem due to lack of native support of GMP in the Openshift server stack.
The app works fine in development because GMP is installed in my development environment.


Version-Release number of selected component (if applicable):


How reproducible:
Simply push a RoR app with a line "gem gmp" in its Gemfile. All versions of the gem will fail to bundle install on the Openshift server.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Meng Bo 2013-07-10 05:56:45 EDT
Checked on devenv_3473, gmp can be installed for ruby app.

remote: Stopping Ruby cart
remote: Waiting for stop to finish
remote: Running build on Ruby cart
remote: Bundling RubyGems based on Gemfile/Gemfile.lock to repo/vendor/bundle with 'bundle install --deployment'
remote: Fetching gem metadata from https://rubygems.org/..
remote: Installing gmp (0.6.31) with native extensions .
remote: ....................
remote: ..
remote: 
remote: Using bundler (1.1.4) 
remote: Your bundle is complete! It was installed into ./vendor/bundle
remote: Starting Ruby cart
To ssh://51dd2f2a02597e085e000006@ruby19-bmengdev.dev.rhcloud.com/~/git/ruby19.git/
   081c772..ac145a4  master -> master

Note You need to log in before you can comment on or make changes to this bug.