Bug 982609 - poor handling of window resize
poor handling of window resize
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bash (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Oprala
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:08 EDT by Martin Kyral
Modified: 2016-01-31 21:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 06:42:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2013-07-09 08:08:48 EDT
Description of problem:
When there is a longer text output displayed in bash in window

Version-Release number of selected component (if applicable):
bash-3.2-32.el5_9.1

How reproducible:
always


Steps to Reproduce:
1. in GUI terminal (xterm, konsole, gnome-terminal..) run man bash | col -b
2. resize the window to less than 80 chars (the narowwer the window is, the more is the issue visible)
3. resize the window back to be wider than 80 chars

Actual results:
1. man page is displayed with the width of 80 chars
3. the output is not redrawed properly (incomplete text, misdrawed characters etc. - see the snippet below)

--8<------------------------------------------

BUGS
       It’s too

       There are
       of sh, mo

       Aliases a

       Shell bui

       Compound
       handled
       cess is s
       sequence.
       theses to

       Commands
       substitut
       time afte
       even  ins
       construct

       Array var

       When brea
       more than


--8<------------------------------------------


Expected results:
3. the is displayed exactly the same as in 1. (complete, formatted to the width of 80 chars)

--8<------------------------------------------

BUGS
       It’s too big and too slow.

       There are some subtle differences between bash and traditional versions
       of sh, mostly because of the POSIX specification.

       Aliases are confusing in some uses.

       Shell builtin commands and functions are not stoppable/restartable.

       Compound commands and command sequences of the form ‘a ; b ; c’ are not
       handled  gracefully  when process suspension is attempted.  When a pro-
       cess is stopped, the shell immediately executes the next command in the
       sequence.  It suffices to place the sequence of commands between paren-
       theses to force it into a subshell, which may be stopped as a unit.

       Commands inside of $(...) command substitution  are  not  parsed  until
       substitution  is attempted.  This will delay error reporting until some
       time after the command is entered.  For example, unmatched parentheses,
       even  inside  shell  comments,  will result in error messages while the
       construct is being read.

       Array variables may not (yet) be exported.

       When breaking out of multiple loops, if the outermost loop consists  of
       more than one command, the exit status of break and continue is lost.



GNU Bash-3.2                   2006 September 28                       BASH(1)

--8<------------------------------------------

Additional info:
ksh, pdksh seems to behave well. zsh breaks the same or similar way as bash do.
Comment 1 Roman Rakus 2013-07-09 08:12:44 EDT
Hmm, is it really the bug in bash? I thought the man is responsible for the formatting.
Comment 2 Roman Rakus 2013-07-09 08:14:47 EDT
Ah, now I get the point...
Comment 3 Martin Kyral 2013-07-09 08:19:33 EDT
man bash behaves well. "man bash | col -b" causes the man page to be formatted and printed to stdout, then man ends. I should have included the PS1 to the snippet as well, sorry for that.

---8<---------------------------

BUGS
       It’s too

       There are
       of sh, mo

       Aliases a

       Shell bui

       Compound
       handled
       cess is s
       sequence.
       theses to

       Commands
       substitut
       time afte
       even  ins
       construct

       Array var

       When brea
       more than

0 [mkyral@dhcp-27-45 ~ ]$

The window is rendered incorrectly no matter what actual output there is (yum seach).

---8<--------------------------------------
system-config-pr
tetex-afm.x86_64
tetex-dvips.x86_
tetex-xdvi.x86_6
texinfo.x86_64 :
texinfo-tex.x86_
tidy.x86_64 : Ut
tidyp.x86_64 : C
tiresias-fonts.n
uboot-tools.x86_
udunits.x86_64 :
udunits2.i386 :
udunits2.x86_64
virt-what.x86_64
xchm.x86_64 : A
xclip.x86_64 : C
xfig.x86_64 : An
xprobe2.x86_64 :
yapet.x86_64 : C
0 [root@dhcp-27-
Loaded plugins:
This system is n
Warning: No matc
No Matches found
0 [root@dhcp-27-45 ~]#
Comment 4 RHEL Product and Program Management 2014-03-07 08:53:55 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 Ondrej Oprala 2014-05-28 06:42:12 EDT
Since the 5.11 devel phase is over now, I'm closing this bug report.

Note You need to log in before you can comment on or make changes to this bug.