Bug 98261 - ez input method
Summary: ez input method
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xcin   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-29 14:10 UTC by wood
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 05:54:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wood 2003-06-29 14:10:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

Description of problem:
There is an error that ez input medthod can't be use in redhat 9.0'
xcin-2.5.3.pre3-11

The error is from "xcin-2.5.3.pre3-20021117fixes.patch"

because ez.cin input method was replaced by cj.cin,
so will generate the some tab file from the same cj.cin source but with
different name(ez.tab and cj.tab).

to fix this, just change cj.cin to ez.cin

+ez.tab.$(BIG5ENC): ez.cin sys.tab.$(BIG5ENC)
+	$(build) -r $(xcinrc) -l $(BIG5ENC) \
+		-s sys.tab.$(BIG5ENC) -o $@ cj.cin
                                            ^^
                                          Change to ez.cin

 phone.tab.$(BIG5ENC): phone.cin sys.tab.$(BIG5ENC)
 	$(build) -r $(xcinrc) -l $(BIG5ENC) \
 		-s sys.tab.$(BIG5ENC) -o $@ phone.cin
@@ -72,6 +77,9 @@
 cj.tab.$(BIG5HKENC): cj.cin sys.tab.$(BIG5HKENC)
 	$(build) -r $(xcinrc) -l $(BIG5HKENC) \
 		-s sys.tab.$(BIG5HKENC) -o $@ cj.cin

+ez.tab.$(BIG5HKENC): ez.cin sys.tab.$(BIG5HKENC)
+	$(build) -r $(xcinrc) -l $(BIG5HKENC) \
+		-s sys.tab.$(BIG5HKENC) -o $@ cj.cin
                                              ^^
                                          Change to ez.cin

Version-Release number of selected component (if applicable):
xcin-2.5.3.pre3-11

How reproducible:
Always

Steps to Reproduce:
1. edit xcinrc to use ez input method
2. ezin input be same as cj input method
3.
    

Additional info:

Comment 1 Leon Ho 2004-04-01 05:54:22 UTC
Please try xcin in rawhide


Note You need to log in before you can comment on or make changes to this bug.