This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 982613 - poor handling of window resize
poor handling of window resize
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: zsh (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: James Antill
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:12 EDT by Martin Kyral
Modified: 2013-12-10 15:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 15:29:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2013-07-09 08:12:23 EDT
Description of problem:
When there is a longer text output displayed in zsh in window, it is redrawed incorrectly upon resize.

Version-Release number of selected component (if applicable):
zsh-4.2.6-8.el5

How reproducible:
always


Steps to Reproduce:
1. in GUI terminal (xterm, konsole, gnome-terminal..) run man bash | col -b
2. resize the window to less than 80 chars (the narowwer the window is, the more is the issue visible)
3. resize the window back to be wider than 80 chars

Actual results:
1. man page is displayed with the width of 80 chars
3. the output is not redrawed properly (incomplete text, misdrawed characters etc. - see the snippet below)

--8<------------------------------------------

BUGS
       It’s too

       There are
       of sh, mo

       Aliases a

       Shell bui

       Compound
       handled
       cess is s
       sequence.
       theses to

       Commands
       substitut
       time afte
       even  ins
       construct

       Array var

       When brea
       more than


--8<------------------------------------------


Expected results:
3. the is displayed exactly the same as in 1. (complete, formatted to the width of 80 chars)

--8<------------------------------------------

BUGS
       It’s too big and too slow.

       There are some subtle differences between bash and traditional versions
       of sh, mostly because of the POSIX specification.

       Aliases are confusing in some uses.

       Shell builtin commands and functions are not stoppable/restartable.

       Compound commands and command sequences of the form ‘a ; b ; c’ are not
       handled  gracefully  when process suspension is attempted.  When a pro-
       cess is stopped, the shell immediately executes the next command in the
       sequence.  It suffices to place the sequence of commands between paren-
       theses to force it into a subshell, which may be stopped as a unit.

       Commands inside of $(...) command substitution  are  not  parsed  until
       substitution  is attempted.  This will delay error reporting until some
       time after the command is entered.  For example, unmatched parentheses,
       even  inside  shell  comments,  will result in error messages while the
       construct is being read.

       Array variables may not (yet) be exported.

       When breaking out of multiple loops, if the outermost loop consists  of
       more than one command, the exit status of break and continue is lost.



GNU Bash-3.2                   2006 September 28                       BASH(1)

--8<------------------------------------------

Additional info:
ksh, pdksh seems to behave well. bash breaks the same or similar way as zsh do.
see https://bugzilla.redhat.com/show_bug.cgi?id=982609
Comment 1 James Antill 2013-12-10 15:29:19 EST
 It seems to be fixed in RHEL-6 zsh/less. But at this point in RHEL-5 we can't really fix issues like this. If you really need a fix I believe the RHEL-6 version of zsh will build for/on RHEL-5.

Note You need to log in before you can comment on or make changes to this bug.