Bug 982684 - RFE: Add configuration profile support to LVM2
RFE: Add configuration profile support to LVM2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 10:51 EDT by Peter Rajnoha
Modified: 2014-04-23 04:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 04:13:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Rajnoha 2013-07-09 10:51:36 EDT
(This RFE is primarily for QE to make notes on testing this feature, report any findings etc...)

Add support for configuration profiles. A configuration profile is a list of selected customizable configuration settings that are overlayed on top of existing configuration and it's aimed to achieve a certain characteristics in various environments or uses.

Each profile is defined the same way as normal lvm.conf, though it's put in a different directory and it has the .profile suffix to make a difference. The profile can be saved in metadata so it's possible to attach a profile name with the VG/LV and whenever such VG/LV is used next time, the profile is automatically loaded and used.

(also related Fedora bug #958464)

I'll add more details and a test case shortly...
Comment 1 Peter Rajnoha 2014-04-23 04:13:39 EDT
Already verified with bug #1000597 since we have only thin profiles at the moment in RHEL7.0.

Note You need to log in before you can comment on or make changes to this bug.