Bug 982685 - [abrt] remmina-1.0.0-7.fc19: ssh_channel_close: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
[abrt] remmina-1.0.0-7.fc19: ssh_channel_close: Process /usr/bin/remmina was ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
19
x86_64 All
high Severity medium
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
abrt_hash:43e8992c72a148e45ca8883b62a...
:
: 965926 973890 976206 984131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 10:52 EDT by muscat
Modified: 2014-08-18 04:26 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-18 04:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.95 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: core_backtrace (2.24 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: dso_list (12.05 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: environ (1.91 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: maps (60.79 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: open_fds (1.19 KB, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: proc_pid_status (943 bytes, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
File: var_log_messages (730 bytes, text/plain)
2013-07-09 10:52 EDT, muscat
no flags Details
Check-for-NULL-pointers-in-channel.c.patch (3.19 KB, patch)
2013-07-12 06:19 EDT, Igor Gnatenko
no flags Details | Diff
Check-for-NULL-pointers-in-ssh_channel_close.patch (501 bytes, patch)
2013-07-12 10:43 EDT, Igor Gnatenko
no flags Details | Diff
0001-Check-for-NULL-pointers-in-ssh_channel_close.patch () (768 bytes, patch)
2013-07-13 06:26 EDT, Igor Gnatenko
no flags Details | Diff

  None (edit)
Description muscat 2013-07-09 10:52:00 EDT
Version-Release number of selected component:
remmina-1.0.0-7.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/remmina
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ssh_channel_close at /usr/src/debug/libssh-0.5.4/src/channels.c:1086
 #1 channel_close at /usr/src/debug/libssh-0.5.4/src/legacy.c:59
 #2 remmina_ssh_tunnel_close_all_channels at /usr/src/debug/FreeRDP-Remmina-356c033/remmina/src/remmina_ssh.c:596
 #3 remmina_ssh_tunnel_free at /usr/src/debug/FreeRDP-Remmina-356c033/remmina/src/remmina_ssh.c:1209
 #4 remmina_protocol_widget_close_connection at /usr/src/debug/FreeRDP-Remmina-356c033/remmina/src/remmina_protocol_widget.c:283
 #5 remmina_connection_window_delete_event at /usr/src/debug/FreeRDP-Remmina-356c033/remmina/src/remmina_connection_window.c:193
 #6 _gtk_marshal_BOOLEAN__BOXEDv at gtkmarshalers.c:130
 #7 _g_closure_invoke_va at gclosure.c:840
 #10 gtk_widget_event_internal at gtkwidget.c:6714
 #11 gtk_widget_event at gtkwidget.c:6371

Potential duplicate: bug 965926
Comment 1 muscat 2013-07-09 10:52:05 EDT
Created attachment 771071 [details]
File: backtrace
Comment 2 muscat 2013-07-09 10:52:10 EDT
Created attachment 771072 [details]
File: cgroup
Comment 3 muscat 2013-07-09 10:52:14 EDT
Created attachment 771073 [details]
File: core_backtrace
Comment 4 muscat 2013-07-09 10:52:22 EDT
Created attachment 771074 [details]
File: dso_list
Comment 5 muscat 2013-07-09 10:52:28 EDT
Created attachment 771075 [details]
File: environ
Comment 6 muscat 2013-07-09 10:52:32 EDT
Created attachment 771076 [details]
File: limits
Comment 7 muscat 2013-07-09 10:52:37 EDT
Created attachment 771077 [details]
File: maps
Comment 8 muscat 2013-07-09 10:52:41 EDT
Created attachment 771078 [details]
File: open_fds
Comment 9 muscat 2013-07-09 10:52:48 EDT
Created attachment 771079 [details]
File: proc_pid_status
Comment 10 muscat 2013-07-09 10:52:52 EDT
Created attachment 771080 [details]
File: var_log_messages
Comment 11 Igor Gnatenko 2013-07-12 04:34:14 EDT
I closed RDP connection
Comment 12 Igor Gnatenko 2013-07-12 04:35:22 EDT
RPD over SSH
Comment 13 Igor Gnatenko 2013-07-12 05:28:05 EDT
Maintainers, include this patch to libssh.
http://git.libssh.org/projects/libssh.git/commit/?id=11e54e82216e1a07d90f7e4db9572ea96d036350
Comment 14 Igor Gnatenko 2013-07-12 06:19:54 EDT
Created attachment 772626 [details]
Check-for-NULL-pointers-in-channel.c.patch

http://koji.fedoraproject.org/koji/taskinfo?taskID=5597794
Comment 15 Igor Gnatenko 2013-07-12 06:23:25 EDT
*** Bug 965926 has been marked as a duplicate of this bug. ***
Comment 16 Igor Gnatenko 2013-07-12 10:43:37 EDT
Created attachment 772750 [details]
Check-for-NULL-pointers-in-ssh_channel_close.patch

v2. For this bug not needed many checks.
Comment 17 Igor Gnatenko 2013-07-12 10:44:39 EDT
*** Bug 976206 has been marked as a duplicate of this bug. ***
Comment 18 Igor Gnatenko 2013-07-13 06:26:30 EDT
Created attachment 772996 [details]
0001-Check-for-NULL-pointers-in-ssh_channel_close.patch ()

v3. Create patch from git libssh-0.5.4
http://koji.fedoraproject.org/koji/taskinfo?taskID=5603520
Comment 19 Igor Gnatenko 2013-07-13 07:09:35 EDT
*** Bug 973890 has been marked as a duplicate of this bug. ***
Comment 20 Igor Gnatenko 2013-07-13 07:09:39 EDT
*** Bug 984131 has been marked as a duplicate of this bug. ***
Comment 22 Simone Caronni 2013-07-16 02:40:07 EDT
Tested with Guacamole+SSH and Remmina+SSH, it seems there are no regressions.
Comment 23 Fedora Update System 2013-07-16 02:50:32 EDT
libssh-0.5.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libssh-0.5.4-4.fc17
Comment 24 Fedora Update System 2013-07-16 02:50:55 EDT
libssh-0.5.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libssh-0.5.4-4.fc18
Comment 25 Fedora Update System 2013-07-16 02:51:20 EDT
libssh-0.5.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libssh-0.5.4-4.fc19
Comment 26 Fedora Update System 2013-07-16 02:52:27 EDT
libssh-0.5.4-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/libssh-0.5.4-4.el6
Comment 27 Fedora Admin XMLRPC Client 2013-07-16 05:28:20 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 28 Igor Gnatenko 2013-07-16 06:04:29 EDT
ah. I'm sorry. problem in remmina.
remmina send to ssh_connection_close undefined pointers https://github.com/FreeRDP/Remmina/issues/217
But this update in libssh is useful.
Comment 29 Simone Caronni 2013-07-16 06:17:55 EDT
Changed from "bugfix" to "enhancement" as requested in Bodhi and removed the bug number in the updates for f17+ and el6.
Comment 30 Christoph Wickert 2013-07-16 06:31:31 EDT
(In reply to Igor Gnatenko from comment #28)
> remmina send to ssh_connection_close undefined pointers
> https://github.com/FreeRDP/Remmina/issues/217

Thanks, I am watching the upstream bug now.
Comment 31 Resa Drijsen 2013-07-22 03:07:14 EDT
The error was raised when disconnecting from the remote client.
Connection was made using the NX plugin from Remmina

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        remmina
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.9.9-302.fc19.x86_64
package:        remmina-1.0.0-7.fc19
reason:         Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 32 muscat 2013-07-30 03:00:49 EDT
just close session

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        remmina
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.9.9-302.fc19.x86_64
package:        remmina-1.0.0-7.fc19
reason:         Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 33 muscat 2013-10-10 05:11:51 EDT
close window with connection to remote machine

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        remmina -i
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.11.2-201.fc19.x86_64
package:        remmina-1.0.0-7.fc19
reason:         Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 34 Andrew Ivanov 2013-10-20 08:58:20 EDT
Occurs everytime on closing remote desktop window. Running RDP over SSH.
Was able to reproduce with VNC over SSH as well.

reporter:       libreport-2.1.8
backtrace_rating: 4
cmdline:        /usr/bin/remmina
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.11.4-201.fc19.x86_64
package:        remmina-1.0.0-7.fc19
reason:         Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 35 David 2014-01-02 03:36:52 EST
Another user experienced a similar problem:

I had just completed a VNC connection to a linux host over ssh. It worked perfectly, but when I disconnect I seem to get the same error. It is repeatable.

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /usr/bin/remmina
crash_function: ssh_channel_close
executable:     /usr/bin/remmina
kernel:         3.12.5-200.fc19.x86_64
package:        remmina-1.0.0-7.fc19
reason:         remmina killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 36 Christoph Wickert 2014-05-22 07:35:08 EDT
Assigning bug to new package maintainer.
Comment 37 Pavel Alexeev 2014-08-18 04:26:14 EDT
Thank very much bug report and willing make free software better.

As I already use remmina in my day job I really try fix known issues and make it up to date. Unfortunately it is big project which is poorly maintained upstream for long time. In prepare new release of freerdp and remmina we hope it may be changed now. Remmina still have many opened issues some of opened for years. Meantime some of major have trend to resolve (for example not official path to solve clipboard issue https://github.com/FreeRDP/Remmina/issues/280#issuecomment-51663311 already in rawhide).

So have such problems unfortunately became near impossible maintain such fixes in stable Fedora versions.
With help of Simone Caronni we have new version 1.0.0 from git master branch which promise some enhancements as well and based on freerdp 1.1.0 released recently. I can suggest for everyone to try that.

Please reopen if you problem still reproduced on that version.

Note You need to log in before you can comment on or make changes to this bug.