Bug 982701 - [abrt] ovirt-engine-cli-3.2.0.12-1.fc17: pkg_resources.py:588:resolve:DistributionNotFound: pexpect-u>=2.3
[abrt] ovirt-engine-cli-3.2.0.12-1.fc17: pkg_resources.py:588:resolve:Distrib...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ovirt-engine-cli (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ofer Schreiber
Fedora Extras Quality Assurance
abrt_hash:0f4b95a862be50ca086de699854...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 11:34 EDT by Soeren Grunewald
Modified: 2015-11-15 20:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 02:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.24 KB, text/plain)
2013-07-09 11:34 EDT, Soeren Grunewald
no flags Details
File: core_backtrace (399 bytes, text/plain)
2013-07-09 11:34 EDT, Soeren Grunewald
no flags Details
File: environ (3.45 KB, text/plain)
2013-07-09 11:34 EDT, Soeren Grunewald
no flags Details

  None (edit)
Description Soeren Grunewald 2013-07-09 11:34:26 EDT
Description of problem:
Just typed:
$  ovirt-shell --help

Version-Release number of selected component:
ovirt-engine-cli-3.2.0.12-1.fc17

Additional info:
cmdline:        /usr/bin/python /usr/bin/ovirt-shell --help
dso_list:       python-setuptools-0.6.27-2.fc17.noarch
executable:     /usr/bin/ovirt-shell
kernel:         3.9.7-100.fc17.x86_64
runlevel:       N 5
uid:            1000
ureports_counter: 1

Truncated backtrace:
pkg_resources.py:588:resolve:DistributionNotFound: pexpect-u>=2.3

Traceback (most recent call last):
  File "/usr/bin/ovirt-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2735, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
DistributionNotFound: pexpect-u>=2.3

Local variables in innermost frame:
dist: None
to_activate: [ovirt-shell 3.2.0.12-SNAPSHOT (/usr/lib/python2.7/site-packages), kitchen 1.1.1 (/usr/lib/python2.7/site-packages), ply 3.4 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('pexpect-u>=2.3')
requirements: [Requirement.parse('ovirt-engine-sdk>=3.2.0.11-SNAPSHOT')]
processed: {Requirement.parse('ply>=3.3'): True, Requirement.parse('kitchen>=1'): True, Requirement.parse('ovirt-shell==3.2.0.12-SNAPSHOT'): True}
env: <pkg_resources.Environment object at 0x2586fd0>
installer: None
self: <pkg_resources.WorkingSet object at 0x2577f50>
best: {'pexpect-u': None}
replacement: True
Comment 1 Soeren Grunewald 2013-07-09 11:34:32 EDT
Created attachment 771098 [details]
File: backtrace
Comment 2 Soeren Grunewald 2013-07-09 11:34:37 EDT
Created attachment 771099 [details]
File: core_backtrace
Comment 3 Soeren Grunewald 2013-07-09 11:34:40 EDT
Created attachment 771100 [details]
File: environ
Comment 4 jas 2013-07-12 15:52:52 EDT
Just to note that the same error occurs under RHEL6 with the 3.2 ovirt-engine-cli RPM..

# ovirt-shell --help
Traceback (most recent call last):
  File "/usr/bin/ovirt-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pexpect-u>=2.3
Comment 5 jas 2013-07-12 15:58:26 EDT
In addition, while not the "answer", this resolved the error for me:

easy_install  http://pypi.python.org/packages/3.2/p/pexpect-u/pexpect_u-2.5.1-py3.2.egg
Comment 6 Fedora End Of Life 2013-08-01 02:24:37 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.