Bug 982720 - [abrt] evolution-3.8.3-2.fc19: talloc_abort: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
[abrt] evolution-3.8.3-2.fc19: talloc_abort: Process /usr/bin/evolution was k...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:c91dcae1bb5412f10d1f46d54c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 12:29 EDT by Nathan Crubel
Modified: 2014-06-23 10:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-23 10:59:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (68.04 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: cgroup (142 bytes, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: core_backtrace (2.26 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: dso_list (39.05 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: environ (2.00 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: maps (185.95 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: open_fds (2.64 KB, text/plain)
2013-07-09 12:29 EDT, Nathan Crubel
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-07-09 12:30 EDT, Nathan Crubel
no flags Details
File: var_log_messages (1.41 KB, text/plain)
2013-07-09 12:30 EDT, Nathan Crubel
no flags Details
File: xsession_errors (9.55 KB, text/plain)
2013-07-09 12:30 EDT, Nathan Crubel
no flags Details

  None (edit)
Description Nathan Crubel 2013-07-09 12:29:35 EDT
Version-Release number of selected component:
evolution-3.8.3-2.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/evolution
crash_function: talloc_abort
executable:     /usr/bin/evolution
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 talloc_abort at ../talloc.c:338
 #3 talloc_abort_access_after_free at ../talloc.c:357
 #4 talloc_chunk_from_ptr at ../talloc.c:378
 #6 __talloc at ../talloc.c:578
 #7 talloc_named at ../talloc.c:1233
 #8 Release at libmapi/IUnknown.c:134
 #9 mapi_object_release at libmapi/mapi_object.c:97
 #10 e_mapi_connection_close_folder at e-mapi-connection.c:1245
 #11 camel_mapi_folder_fetch_summary at camel-mapi-folder.c:872
 #12 mapi_refresh_folder at camel-mapi-folder.c:954

Potential duplicate: bug 871799
Comment 1 Nathan Crubel 2013-07-09 12:29:40 EDT
Created attachment 771112 [details]
File: backtrace
Comment 2 Nathan Crubel 2013-07-09 12:29:42 EDT
Created attachment 771113 [details]
File: cgroup
Comment 3 Nathan Crubel 2013-07-09 12:29:45 EDT
Created attachment 771114 [details]
File: core_backtrace
Comment 4 Nathan Crubel 2013-07-09 12:29:48 EDT
Created attachment 771115 [details]
File: dso_list
Comment 5 Nathan Crubel 2013-07-09 12:29:50 EDT
Created attachment 771116 [details]
File: environ
Comment 6 Nathan Crubel 2013-07-09 12:29:53 EDT
Created attachment 771117 [details]
File: limits
Comment 7 Nathan Crubel 2013-07-09 12:29:56 EDT
Created attachment 771118 [details]
File: maps
Comment 8 Nathan Crubel 2013-07-09 12:29:59 EDT
Created attachment 771119 [details]
File: open_fds
Comment 9 Nathan Crubel 2013-07-09 12:30:02 EDT
Created attachment 771120 [details]
File: proc_pid_status
Comment 10 Nathan Crubel 2013-07-09 12:30:04 EDT
Created attachment 771121 [details]
File: var_log_messages
Comment 11 Nathan Crubel 2013-07-09 12:30:07 EDT
Created attachment 771122 [details]
File: xsession_errors
Comment 12 Milan Crha 2013-07-10 05:32:16 EDT
Thanks for a bug report. I see in the var_log_messages that the two evolution processes have some trouble:

> Jul  9 10:34:21 uslt93531 kernel: [87203.212393] Pid 3714(evolution-alarm)
> over core_pipe_limit
> Jul  9 11:19:31 uslt93531 kernel: [89916.399116] Pid 4478(evolution) over
> core_pipe_limit

And almost 30 seconds later, the evolution process is killed due to SIGSEGV. The list of opened files is pretty short, which is suspicious, because evolution use to have opened more than 32 files, almost always (counting also libraries).

I checked the code and it seems to me that the code is correct, at least when reading it. The talloc claims "Bad talloc magic value - access after free", on a usage of a 'session', which might mean that the connection was disconnected for some reason. Do you recall whether any disconnect happened before the crash, or basically any detail which would help to identify the crash cause, please?
Comment 13 Nathan Crubel 2014-06-23 10:59:18 EDT
I am thinking there was an issue connecting to the exchange servers. Closing the ticket.

Note You need to log in before you can comment on or make changes to this bug.