Bug 98273 - (ISDN PCMCIA)system lockup upon stopping isdn
(ISDN PCMCIA)system lockup upon stopping isdn
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 05:14 EDT by Need Real Name
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-16 01:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-30 05:14:29 EDT
Description of problem:

Restarting or stopping the service isdn locks system,
this happens in the running system but also upon
shutdown. 

Version-Release number of selected component (if applicable):

redhat-network-config: 1.2.13-1 and 1.3.1-1

redhat-network-config-tui: 1.2.13-1 and 1.3.1-1

How reproducible:

Always

Steps to Reproduce:
1. /etc/rc.d/init.d/isdn stop
2. /etc/rc.d/init.d/isdn restart
3. Menu Services isdn stop
    
Actual results:

System lockup without error message, no error log entry

Expected results:


Additional info:

starting isdn causes no problems
Comment 1 Ngo Than 2003-06-30 06:14:04 EDT
for debugging, i need some infos:

 which kernel version do you have on your machine?

 which isdn card do you have?

 please send to me your isdn config files
 /etc/sysconfig/network-scripts/ifcfg-ipppX /etc/sysconfig/isdncard

Comment 2 Need Real Name 2003-06-30 06:41:01 EDT
Thabnk you for the quick response. Here is the information you asked for:

uname -a on my machine outputs:
Linux my_pc_name 2.4.20-8 #1 i686 i686 i386 GNU/linux

I use an AVM Fritz PCMCIA isdn Card

The content of /etc/sysconfug/isdncard:

VENDOR_ID=
FIRMWARE=
NAME='AVM Fritz Card PCMCIA'
MODULE=avma1_cs
RESOURCES='protocol=2'

There is no ifcfg-ippp0 in /etc/sysconfig/network-scripts, only
ifcfg-Tiscali (Tiscali is the name of my provider). 
The contents of this file:

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
USERCTL=yes
PEERDNS=yes
TYPE=ISDN
DEVICE=ippp0
BOOTPROTO=dialup
ONBOOT=no
DEFROUTE=no
PERSIST=off
SECURE=off
BUNDLING=on
HUPTIMEOUT=600
DIALMODE=manual
ENCAP=syncppp
USER=silke.maurer
PHONE_OUT=0193792
AUTH='+pap -chap'
PROVIDER=Tiscali
CALLBACK=off
CCP=on
PC=on
AC=on
BSDCOMP=on
VJ=on
VJCCOMP=on
NAME=Tiscali
DEMAND=no
SLAVE_DEVICE=ippp1

Perhaps the error has to do with the name of this file?
Comment 3 Ngo Than 2003-06-30 09:38:34 EDT
it looks like a problem in isdn driver. I assigned it to correct component
Comment 4 Need Real Name 2003-07-01 02:17:37 EDT
Removing
redhat-network-config 1.2.13-1 or 1.3.1-1 and
redhat-network-config-tui 1.2.13-1 or 1.3.1-1

and reinstalling 
redhat-network-config 1.2.0-2 and
redhat-network-config-tui 1.2.0-2

eliminates the above problem.

Is it perhaps necessary for me to match the isdn4k-utils 
(currently 3.1-62) to the redhat-network-config releases? 
Comment 5 Need Real Name 2003-07-01 05:24:31 EDT
Removing
redhat-network-config 1.2.13-1 or 1.3.1-1 and
redhat-network-config-tui 1.2.13-1 or 1.3.1-1

and reinstalling 
redhat-network-config 1.2.0-2 and
redhat-network-config-tui 1.2.0-2

eliminates the above problem.

Is it perhaps necessary for me to match the isdn4k-utils 
(currently 3.1-62) to the redhat-network-config releases? 
Comment 6 Ngo Than 2003-07-02 13:13:52 EDT
strange, redhat-config-network is only used for creating network config files.
It cannot cause such problem, because your config files look ok for me!

Are you sure that you only downgraded redhat-config-network? nothing else?

Have you reconfigured your isdn card with 1.2.0-2?
Comment 7 Need Real Name 2003-07-08 11:33:01 EDT
You are right, of course. I have repeated the up and downgrading of the
redaht-network-config packets, and now the lock up problem prevailes.
Also, stopping the pcmcia service causes a lockup
The removal of isdn4k-utils also causes a lock up.
A forced installation of isdn4k-utils works but changes nothing
The problem seems to be at the stage of loading the isdn-module
during boot, which fails.
After all this, I should congratulate you to the journaling file system!
I will continue to try to find the cause, perhaps you have a tip or two?
Comment 8 Need Real Name 2003-07-16 01:52:22 EDT
Installation of Shrike 9A has resolved the problems

Note You need to log in before you can comment on or make changes to this bug.