Bug 98276 - ipop3d does not give an error if can't access /var/spool/mail
ipop3d does not give an error if can't access /var/spool/mail
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 07:41 EDT by Toni Willberg
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 05:11:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2003-06-30 07:41:31 EDT
imap-2001a-15

I installed imap package for pop services, enable it from xinetd and fired up
xinet service. Next I copied /var/spool/mail from other computer. After 6 hours
I started wondering where are all the new mail..? :)


It seems that even xinetd/pop3 is running as root, it can't access
/var/spool/mail if it has 700 permissions. After I did set 755 it works fine.

The actual problem:
*When it can't access the mail spool, it gives no errors in any of logfiles.*


Here's /etc/xinetd.d/ipop3:

service pop3
{
        socket_type             = stream
        wait                    = no
        user                    = root
        server                  = /usr/sbin/ipop3d
        log_on_success  += HOST DURATION
        log_on_failure  += HOST
        disable                 = no
}

It claims it's running as root, but it perhaps does some internal stupidity. :)
Comment 1 Toni Willberg 2003-06-30 07:56:20 EDT
for clarification:

the end user also receives no error, it just looks like there is no mail for him
Comment 2 Mike A. Harris 2004-02-27 05:09:35 EST
The proper permissions for /var/spool/mail, as supplied by a default
OS installation, are mode 0775.  If your mail spool directory is
mode 0700, it has been changed by someone incorrectly and mail
will not work correctly.  This is not a bug, but a misconfiguration
on your end.
Comment 3 Mike A. Harris 2004-02-27 05:11:39 EST
Just as an additional note, Red Hat Linux 8.0 is no longer supported
by Red Hat.  Also, UW imap has been dropped from our current
development tree and is being replaced with alternative IMAP
software dovecot, and cyrus-imapd.

Note You need to log in before you can comment on or make changes to this bug.