Bug 982792 - PackStack Single Node Deployment requires MySQL port open in firewall
PackStack Single Node Deployment requires MySQL port open in firewall
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
unspecified Severity unspecified
: ---
: 4.0
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 18:18 EDT by beejee123
Modified: 2013-08-09 09:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 09:23:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
20130709-142126-v0H_NE.packstak.log (11.44 KB, text/plain)
2013-07-09 18:18 EDT, beejee123
no flags Details
success-20130709-144320-fGCciP-openstack-setup.log (4.02 KB, text/plain)
2013-07-10 14:41 EDT, beejee123
no flags Details

  None (edit)
Description beejee123 2013-07-09 18:18:51 EDT
Created attachment 771283 [details]
20130709-142126-v0H_NE.packstak.log

Document URL: https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack_Preview/3/html-single/Getting_Started_Guide/index.html

Section Number and Name: Procedure 4.1. Quick Start Deployment using PackStack

Describe the issue: When running the PackStack single node deployment as per the guide, the installation fails mid-way.  In looking at the log it seemed to me that the scripts were failing because the MySQL port wasn't open in the firewall.  The installation guide that doesn't use PackStack explicitly tells the user to open port 3306 in the firewall prior to manual step-by-step installation.

-A INPUT -p tcp -m multiport --dports 3306 -j ACCEPT

After updating /etc/sysconfig/iptables with the rule above and rerunning the PackStack single node deployment, the installation completed successfully.

Suggestions for improvement: Update the document to include the new firewall rule prior to having user start the PackStack single node deployment if this truly is a requirement - which it appears to be.

Additional information: See attached log
Comment 2 Stephen Gordon 2013-07-09 22:31:52 EDT
(In reply to bgaisford from comment #0)
> Describe the issue: When running the PackStack single node deployment as per
> the guide, the installation fails mid-way.  In looking at the log it seemed
> to me that the scripts were failing because the MySQL port wasn't open in
> the firewall.  

I assume you are referring to this error or was there another I missed?:

2013-07-09 14:25:27::INFO::ospluginutils::139::root:: Ignoring expected error during puppet run /var/tmp/packstack/20130709-142126-v0H_NE/manifests/192.168.124.128_mysql.pp : err: Could not prefetch database_grant provider 'mysql': Command mysql is missing

I notice that installation of nova-compute actually failed because yum couldn't download libvirt-client-0.10.2-18.el6_4.9.x86_64, so there are a few things going on here.

> The installation guide that doesn't use PackStack explicitly
> tells the user to open port 3306 in the firewall prior to manual
> step-by-step installation.
> 
> -A INPUT -p tcp -m multiport --dports 3306 -j ACCEPT
> 
> After updating /etc/sysconfig/iptables with the rule above and rerunning the
> PackStack single node deployment, the installation completed successfully.

Do you have the log of the successful installation as well in case any warnings/errors remained that were not reported interactively?

> Suggestions for improvement: Update the document to include the new firewall
> rule prior to having user start the PackStack single node deployment if this
> truly is a requirement - which it appears to be.

PackStack is not meant to have such a requirement, and hasn't previously to my knowledge. I'm moving to the openstack-packstack component for the developers to review. Can you please confirm which version of the openstack-packstack package is installed though?
Comment 3 beejee123 2013-07-10 14:39:45 EDT
(In reply to Stephen Gordon from comment #2)
> (In reply to bgaisford from comment #0)
> > Describe the issue: When running the PackStack single node deployment as per
> > the guide, the installation fails mid-way.  In looking at the log it seemed
> > to me that the scripts were failing because the MySQL port wasn't open in
> > the firewall.  
> 
> I assume you are referring to this error or was there another I missed?:
> 
> 2013-07-09 14:25:27::INFO::ospluginutils::139::root:: Ignoring expected
> error during puppet run
> /var/tmp/packstack/20130709-142126-v0H_NE/manifests/192.168.124.128_mysql.pp
> : err: Could not prefetch database_grant provider 'mysql': Command mysql is
> missing

I'm not entirely sure the error above was the specific error that got me thinking it was the missing 3306 rule in the firewall.  I would say it was more a hunch than anything.

> 
> I notice that installation of nova-compute actually failed because yum
> couldn't download libvirt-client-0.10.2-18.el6_4.9.x86_64, so there are a
> few things going on here.
> 
> > The installation guide that doesn't use PackStack explicitly
> > tells the user to open port 3306 in the firewall prior to manual
> > step-by-step installation.
> > 
> > -A INPUT -p tcp -m multiport --dports 3306 -j ACCEPT
> > 
> > After updating /etc/sysconfig/iptables with the rule above and rerunning the
> > PackStack single node deployment, the installation completed successfully.
> 
> Do you have the log of the successful installation as well in case any
> warnings/errors remained that were not reported interactively?

I'll attach the successful log: success-20130709-144320-fGCciP-openstack-setup.log

> 
> > Suggestions for improvement: Update the document to include the new firewall
> > rule prior to having user start the PackStack single node deployment if this
> > truly is a requirement - which it appears to be.
> 
> PackStack is not meant to have such a requirement, and hasn't previously to
> my knowledge. I'm moving to the openstack-packstack component for the
> developers to review. Can you please confirm which version of the
> openstack-packstack package is installed though?

Name        : openstack-packstack
Arch        : noarch
Version     : 2013.1.1
Release     : 0.20.dev632.el6ost
Size        : 1.6 M
Repo        : installed
From repo   : rhel-server-ost-6-3-rpms
Summary     : Openstack Install Utility

I wish there was more info I could give you to go on.  Is there any chance it could have been a network hicup/timeout on the yum call to fetch libvirt-client-0.10.2-18.el6_4.9.x86_64?
Comment 4 beejee123 2013-07-10 14:41:24 EDT
Created attachment 771770 [details]
success-20130709-144320-fGCciP-openstack-setup.log
Comment 5 Stephen Gordon 2013-07-10 15:34:26 EDT
(In reply to bgaisford from comment #3)

> I wish there was more info I could give you to go on.  Is there any chance
> it could have been a network hicup/timeout on the yum call to fetch
> libvirt-client-0.10.2-18.el6_4.9.x86_64?

To me it seems likely that this is the primary cause of failure, that you happened to change the firewall before rerunning and then it worked may just be a coincidence. My understanding is that the Puppet manifests uses by PackStack will add any rules the deployment requires in iptables.

Regardless I've moved it to the openstack-packstack component for the developers to look at.
Comment 6 Martin Magr 2013-08-09 09:23:16 EDT
Packstack is enabling such port:
[para@elysium packstack]$ cat packstack/puppet/templates/mysql.pp | grep -A5 -B2 3306
firewall { '001 mysql incoming':
    proto    => 'tcp',
    dport    => ['3306'],
    action   => 'accept',
}

The "Could not prefetch database_grant provider 'mysql'" error happens when /root/.my.cnf is missing in the beginning of manifest application. The file is created later, so this error is ignored.

As Stephen wrote, your problem was that yum could not install libvirt-client package.

Note You need to log in before you can comment on or make changes to this bug.