Bug 982794 - LVM failure after upgrade to Fedora 19
LVM failure after upgrade to Fedora 19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 18:27 EDT by jgforbes
Modified: 2013-08-02 09:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 09:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvmdump output file (30.85 KB, application/x-compressed-tar)
2013-07-09 18:27 EDT, jgforbes
no flags Details

  None (edit)
Description jgforbes 2013-07-09 18:27:52 EDT
Created attachment 771284 [details]
lvmdump output file

Description of problem:
I recently upgrade to Fedora 19 from 17. Fedup did not work correctly, so I did a clean install on the system disk.
However, I have a data disk that is raid-1 and has a volume group and logical volumes that were create under Fedora 17
and was not giving any errors. Now with Fedora 19 on mounting the logical volume, the following errors are reported:

[  130.432660] Buffer I/O error on device dm-1, logical block 119570432
[  130.432664] lost page write due to I/O error on dm-1
[  130.432674] JBD2: Error -5 detected when updating journal superblock for dm-1-8.
[  130.432701] Aborting journal on device dm-1-8.
[  130.432705] Buffer I/O error on device dm-1, logical block 119570432
[  130.432706] lost page write due to I/O error on dm-1
[  130.432708] JBD2: Error -5 detected when updating journal superblock for dm-1-8.
[  218.261625] EXT4-fs (dm-1): previous I/O error to superblock detected
[  218.261640] Buffer I/O error on device dm-1, logical block 0
[  218.261642] lost page write due to I/O error on dm-1
[  218.261644] EXT4-fs error (device dm-1): __ext4_journal_start_sb:60: Detected aborted journal
[  218.261647] EXT4-fs (dm-1): Remounting filesystem read-only
[  218.261649] EXT4-fs (dm-1): previous I/O error to superblock detected
[  218.261653] Buffer I/O error on device dm-1, logical block 0
[  218.261654] lost page write due to I/O error on dm-1


I don't think that this is a hardware problem as everything was working fine before the upgrade to Fedora 19




How reproducible:

Always


Additional info:
# lsblk
NAME                   MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                      8:0    0 119.2G  0 disk  
└─md126                  9:126  0 238.5G  0 raid0 
  ├─md126p1            259:0    0   500M  0 md    /boot
  └─md126p2            259:1    0   238G  0 md    
    ├─vg_fastdog0-root 253:0    0  97.7G  0 lvm   /
    ├─vg_fastdog0-tmp  253:3    0   9.8G  0 lvm   /tmp
    └─vg_fastdog0-home 253:4    0 130.6G  0 lvm   /home
sdb                      8:16   0 119.2G  0 disk  
└─md126                  9:126  0 238.5G  0 raid0 
  ├─md126p1            259:0    0   500M  0 md    /boot
  └─md126p2            259:1    0   238G  0 md    
    ├─vg_fastdog0-root 253:0    0  97.7G  0 lvm   /
    ├─vg_fastdog0-tmp  253:3    0   9.8G  0 lvm   /tmp
    └─vg_fastdog0-home 253:4    0 130.6G  0 lvm   /home
sdc                      8:32   0 931.5G  0 disk  
└─sdc1                   8:33   0 931.5G  0 part  
sdd                      8:48   0 931.5G  0 disk  
└─sdd1                   8:49   0 931.5G  0 part  
sde                      8:64   1   7.5G  0 disk  
└─sde1                   8:65   1   7.5G  0 part  
sr0                     11:0    1   4.1G  0 rom   


See attached file
Comment 1 jgforbes 2013-07-14 08:32:57 EDT
Backed up the raid array.
Zero'ed disks
rebuilt raid
rebuilt lvm group and volumes
restored data.
All worked correctly until after a reboot.
Comment 2 jgforbes 2013-07-14 15:24:30 EDT
looks like kernel-3.9.9-302.fc19.x86_64
fixed the problem

Note You need to log in before you can comment on or make changes to this bug.