Bug 982907 - there is no symlink maintained in the /dev/disk/by-path/ directory for persistent naming device
there is no symlink maintained in the /dev/disk/by-path/ directory for persis...
Status: CLOSED DUPLICATE of bug 950239
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 02:18 EDT by Sibiao Luo
Modified: 2013-11-19 10:50 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 10:50:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-07-10 02:18:57 EDT
Description of problem:
there is no symlink maintained in the /dev/disk/by-path/ directory for persistent naming device, both hit it in host and guest. 
btw, as i did not hit in the past, so this is regression issue, set high priority.

Version-Release number of selected component (if applicable):
host info:
3.10.0-0.rc7.64.el7.x86_64
qemu-kvm-1.5.1-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.check the 
# ls -lh /dev/disk/
total 0
drwxr-xr-x. 2 root root 300 Jul  9 11:42 by-id
drwxr-xr-x. 2 root root 120 Jul  9 11:42 by-uuid
2.
3.

Actual results:


Expected results:
there should have symlink maintained in the /dev/disk/by-path/ directory for persistent naming device.
I tested the rhel6 host, the result like:
# ls -l /dev/disk/
total 0
drwxr-xr-x. 2 root root 420 Jul  3 11:05 by-id
drwxr-xr-x. 2 root root 140 Jul  3 11:05 by-path
drwxr-xr-x. 2 root root 120 Jul  3 11:05 by-uuid
# ls -lh /dev/disk/by-path/*
lrwxrwxrwx. 1 root root  9 Jul  1 14:23 /dev/disk/by-path/ip-10.66.90.100:3260-iscsi-iqn.2001-05.com.equallogic:0-8a0906-0971f7d03-1dff49b26885073d-s2-sluo-172259-lun-0 -> ../../sdb
lrwxrwxrwx. 1 root root  9 Jul  1 13:35 /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0 -> ../../sda
lrwxrwxrwx. 1 root root 10 Jul  1 13:35 /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0-part1 -> ../../sda1
lrwxrwxrwx. 1 root root 10 Jul  1 13:35 /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0-part2 -> ../../sda2
lrwxrwxrwx. 1 root root  9 Jul  1 13:35 /dev/disk/by-path/pci-0000:00:1f.2-scsi-2:0:0:0 -> ../../sr0

Additional info:
Comment 1 Harald Hoyer 2013-11-19 10:50:28 EST

*** This bug has been marked as a duplicate of bug 950239 ***

Note You need to log in before you can comment on or make changes to this bug.