Bug 983006 - Headpin Nightly : Unable to delete org via cli
Headpin Nightly : Unable to delete org via cli
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
sthirugn@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 05:35 EDT by Tazim Kolhar
Modified: 2014-04-24 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Search Org (44.70 KB, image/png)
2013-07-10 05:35 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2013-07-10 05:35:02 EDT
Created attachment 771509 [details]
Search Org

Description of problem:
Unable to delete org via cli

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.827.6cffaee.el6.noarch
katello-cli-1.4.2-1.git.114.78aa037.el6.noarch
katello-cli-common-1.4.2-1.git.114.78aa037.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.827.6cffaee.el6.noarch
katello-headpin-all-1.4.2-1.git.827.6cffaee.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.827.6cffaee.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-headpin-1.4.2-1.git.827.6cffaee.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=****

Steps to Reproduce:
1.Please, refer the latest cli test report
  - http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/job/official-headpin-cli/186/ReportNG_Report/

2.Also, if we try to create manually,

  # ssh root@hp-dl360g4-01.lab.eng.rdu.redhat.com export LANG=en_US && headpin --username "admin" --password **** org create --name "Raleigh-1373446262"
root@hp-dl360g4-01.lab.eng.rdu.redhat.com's password: 
Validation failed: Name has already been taken, Label already exists (including organizations being deleted), Organization Names and labels must be unique across all organizations

3.Try to obtain info for the org it fails

# headpin --username "admin" --password **** org info --name "Raleigh-1373446262"
Couldn't find organization 'Raleigh-1373446262'


Actual results:
Successful deletion of Org

Expected results:
Org deletion failed

Additional info:
Added the UI search the same Org
Comment 1 Tazim Kolhar 2013-07-10 05:37:46 EDT
In the cli test report :
http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/job/official-headpin-cli/186/ReportNG_Report/

ClassName : com.redhat.qe.katello.tests.cli.OrgTests

Methods to refer :
 - test_SLAOrg 
 - test_UploadManifestDiffOrg 
 - test_UploadManifestSameOrg
Comment 3 Tom McKay 2013-10-02 12:49:49 EDT
Was able to successfully delete org. 

It's unclear (since the links to tests are broken) what the root issue is. If this was the case of a script rapidly creating an org and then deleting it, that is a known issue and likely "won't fix." Please don't do that. :)
Comment 4 sthirugn@redhat.com 2013-10-22 14:09:43 EDT
Works for me.

# katello -u admin -p admin shell
katello> org create --name "org1"
Successfully created org [ org1 ]
katello> provider import_manifest --org org1 --name "Red Hat" --file="/tmp/newmanifest.zip"
Provider [ Red Hat ] manifest import complete
katello> org delete --name "org1"
Successfully deleted org [ org1 ]      
katello> org create --name "org1"
Successfully created org [ org1 ]
katello> provider import_manifest --org org1 --name "Red Hat" --file="/tmp/newmanifest.zip"
Provider [ Red Hat ] manifest import complete
katello> org delete --name "org1"
Successfully deleted org [ org1 ]

Version Tested:
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-40.el6sat.noarch
* katello-all-1.4.6-40.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-40.el6sat.noarch
* katello-configure-1.4.7-6.el6sat.noarch
* katello-configure-foreman-1.4.7-6.el6sat.noarch
* katello-foreman-all-1.4.6-40.el6sat.noarch
* katello-glue-candlepin-1.4.6-40.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
* katello-glue-pulp-1.4.6-40.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
Comment 6 Bryan Kearney 2014-04-24 13:08:15 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.