Bug 983021 - nss dependencies are not right
nss dependencies are not right
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 06:05 EDT by Thomas Citharel
Modified: 2013-07-10 11:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 11:51:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Citharel 2013-07-10 06:05:35 EDT
Description of problem:
When trying to upgrade with yum, nss (with all it's dependencies) wants to have version 3.15.1-1 whereas it's 3.15-1.
Seems to be just the same as bug 981166 (just my luck), a problem with pkgconfig giving the wrong version.

And there's surely a problem with the parsing of nss-devel's SPEC file, since pkgconfig(nss-util) appears. 

Version-Release number of selected component (if applicable):
nss-* : 3.15

How reproducible:


Steps to Reproduce:
1. # yum update
2.
3.

Actual results:

(...)

Erreur : Paquet : nss-softokn-3.15.1-1.fc19.x86_64 (updates-testing)
             Requiert : nss-util >= 3.15.1
             Installé  : nss-util-3.15-1.fc19.i686 (installed)
                 nss-util = 3.15-1.fc19
             Disponible : nss-util-3.14.3-1.fc19.i686 (fedora)
                 nss-util = 3.14.3-1.fc19
Erreur : Paquet : nss-3.15.1-1.fc19.x86_64 (updates-testing)
             Requiert : nss-util >= 3.15.1
             Installé  : nss-util-3.15-1.fc19.i686 (installed)
                 nss-util = 3.15-1.fc19
             Disponible : nss-util-3.14.3-1.fc19.i686 (fedora)
                 nss-util = 3.14.3-1.fc19
Erreur : Paquet : nss-softokn-devel-3.15.1-1.fc19.x86_64 (updates-testing)
             Requiert : nss-util-devel >= 3.15.1
             Installé  : nss-util-devel-3.15-1.fc19.x86_64 (@updates)
                 nss-util-devel = 3.15-1.fc19
             Disponible : nss-util-devel-3.14.3-1.fc19.i686 (fedora)
                 nss-util-devel = 3.14.3-1.fc19
Erreur : Paquet : nss-devel-3.15.1-1.fc19.x86_64 (updates-testing)
             Requiert : pkgconfig(nss-util) >= 3.15.1
             Installé  : nss-util-devel-3.15-1.fc19.x86_64 (@updates)
                 pkgconfig(nss-util) = 3.15
             Disponible : nss-util-devel-3.14.3-1.fc19.i686 (fedora)
                 pkgconfig(nss-util) = 3.14.3
Erreur : Paquet : nss-softokn-devel-3.15.1-1.fc19.x86_64 (updates-testing)
             Requiert : pkgconfig(nss-util) >= 3.15.1
             Installé  : nss-util-devel-3.15-1.fc19.x86_64 (@updates)
                 pkgconfig(nss-util) = 3.15
             Disponible : nss-util-devel-3.14.3-1.fc19.i686 (fedora)
                 pkgconfig(nss-util) = 3.14.3
Erreur : Paquet : nss-3.15.1-1.fc19.i686 (updates-testing)
             Requiert : nss-util >= 3.15.1
             Installé  : nss-util-3.15-1.fc19.i686 (installed)
                 nss-util = 3.15-1.fc19
             Disponible : nss-util-3.14.3-1.fc19.i686 (fedora)
                 nss-util = 3.14.3-1.fc19
Erreur : Paquet : nss-softokn-3.15.1-1.fc19.i686 (updates-testing)
             Requiert : nss-util >= 3.15.1
             Installé  : nss-util-3.15-1.fc19.i686 (installed)
                 nss-util = 3.15-1.fc19
             Disponible : nss-util-3.14.3-1.fc19.i686 (fedora)
                 nss-util = 3.14.3-1.fc19
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest


Expected results:
Installation going on.

Additional info:
Comment 1 Thomas Citharel 2013-07-10 11:51:55 EDT
Seems to have been fixed now.

Note You need to log in before you can comment on or make changes to this bug.