Bug 983029 - SY quickstart build.plugins.plugin.version' for org.codehaus.mojo:exec-maven-plugin is missing
SY quickstart build.plugins.plugin.version' for org.codehaus.mojo:exec-maven-...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples, SwitchYard (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: ---
Assigned To: Keith Babo
ppecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 06:25 EDT by ppecka
Modified: 2014-02-06 10:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppecka 2013-07-10 06:25:15 EDT
Description of problem:
     [java] [WARNING] 'build.plugins.plugin.version' for org.codehaus.mojo:exec-maven-plugin is missing. @ line 103, column 21
     [java] [WARNING] 
     [java] [WARNING] Some problems were encountered while building the effective model for org.switchyard.quickstarts:switchyard-quickstart-bpel-service-say-hello:jar:1.0.0.Alpha1
     [java] [WARNING] 'build.plugins.plugin.version' for org.codehaus.mojo:exec-maven-plugin is missing. @ line 36, column 21
     

...

Version: since soa-6.0.0-DR6


Steps to Reproduce:
1. cd quickstarts/switchyard
2. mvn clean install # eg run on parent pom.xml


Actual results:
warning about missing plugin version

Expected results:
warning disappears
Comment 2 Keith Babo 2013-08-02 11:48:04 EDT
This is fixed in SY 1.0.0.Final, so you shouldn't see this behavior in the beta build.
Comment 3 ppecka 2013-08-22 10:34:05 EDT
VERIFIED, issue is fixed
on latest 6.0.0.ER1-redhat-1

Note You need to log in before you can comment on or make changes to this bug.