Bug 983040 - Dist-geo-rep : renames results in deletion of few file from slave.
Dist-geo-rep : renames results in deletion of few file from slave.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 07:06 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-07-10 07:06:49 EDT
Description of problem: After renaming all the files on master, few files gets deleted on the slave. Consider creating 1000 files on the master, and let it sync to slave. Now renaming all the files on the master results in less than thousand files on the slave. 


Version-Release number of selected component (if applicable):glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64


How reproducible:always


Steps to Reproduce:
1.Create and start a geo-rep relationship between master and slave.
2.Create 1000 files on the master of different sizes and let it sync to slave.
3.After it completely synced, rename all the files on master. 
4.Now check it there are 1000 file on the slave after it completes syncing.

Actual results: Geo-rep  deletes few file from the slave


Expected results:Geo-rep shouldn't delete any files from slave unless it is deleted on the master.


Additional info:
Comment 3 Vijaykumar Koppad 2013-07-31 05:39:21 EDT
verified on 3.4.0.14rhs-1.el6rhs.x86_64
Comment 4 Scott Haines 2013-09-23 18:38:43 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:28 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.