Bug 983082 - clarify that fedora-upgrade is not an official upgrade tool
clarify that fedora-upgrade is not an official upgrade tool
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-upgrade (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 08:59 EDT by Kamil Páral
Modified: 2013-07-25 20:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: fedora-upgrade-19.3-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 23:23:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-07-10 08:59:36 EDT
Description of problem:
I just talked to a user who used fedora-upgrade instead of fedup to upgrade his Fedora. There were some problems involved with it (e.g. the upgraded system was missing gnome-session-xsession package), but the core issue is that he used fedora-upgrade without _any suspicion_ that this might not be the official and only upgrade tool.

Please be clearer in stating that fedora-upgrade is an unofficial tool, without formal testing.

I suggest the RPM description and summary is adjusted, because:

$ yum search upgrade
=========== N/S matched: upgrade ================
<snip>
fedora-upgrade.noarch : Upgrade Fedora to next version using yum upgrade
fedup.noarch : The Fedora Upgrade tool
<snip>

People can easily notice just the first line, and they might not know what "using yum upgrade" means or put any weight to it. The package name also sounds official as well.

I suggest changing the summary from:
> Upgrade Fedora to next version using yum upgrade
to
> Upgrade Fedora to next version using yum upgrade (unofficial tool)
or
> Unofficial Fedora upgrade tool using yum upgrade

And description from:
> Upgrade Fedora to next version using yum upgrade.
> This is attempt to automatize steps as listed here:
> https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum
to:
> Upgrade Fedora to next version using yum upgrade.
> This is attempt to automatize steps as listed here:
> https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum
> This is an unofficial tool, for official Fedora-supported
> upgrades please see the 'fedup' tool.

Also, it would be nice if fedora-upgrade printed out some similar information when executed.


Version-Release number of selected component (if applicable):
fedora-upgrade 19.1
Comment 1 Miroslav Suchý 2013-07-15 04:48:47 EDT
Upstream commit 9a9741d.
Fixed in fedora-upgrade-19.3-1
Comment 2 Fedora Update System 2013-07-15 04:57:35 EDT
fedora-upgrade-19.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-upgrade-19.3-1.fc19
Comment 3 Fedora Update System 2013-07-15 21:26:47 EDT
Package fedora-upgrade-19.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-upgrade-19.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12999/fedora-upgrade-19.3-1.fc19
then log in and leave karma (feedback).
Comment 4 Kamil Páral 2013-07-16 04:22:33 EDT
Mirek, do you plan to push this update also to F18? That's the major release people will be upgrading from, at this point.
Comment 5 Miroslav Suchý 2013-07-16 04:32:16 EDT
Hmm, I filed update, but for some reason it had:
  Request: none
I will push it to testing. Thanks for noticing.
Comment 6 Fedora Update System 2013-07-23 23:23:55 EDT
fedora-upgrade-19.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-07-25 20:26:03 EDT
fedora-upgrade-19.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.