This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 98309 - groff fails to correctly parse if-else
groff fails to correctly parse if-else
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 17:28 EDT by Rene Uittenbogaard
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 05:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example mm source code document to reproduce the problem (152 bytes, text/plain)
2003-06-30 17:30 EDT, Rene Uittenbogaard
no flags Details

  None (edit)
Description Rene Uittenbogaard 2003-06-30 17:28:54 EDT
Description of problem:
groff fails to correctly parse if-else if a bulleted list (mm macro) is inside
the if-part

Version-Release number of selected component (if applicable):
groff-1.18-6

How reproducible:
always

Steps to Reproduce:
groff -mm -Tps bl_in_ie.mm > bl_in_ie.ps
or:
nroff -mm  bl_in_ie.mm 
    
Actual results: both the .ie and the .el parts of the conditional are included:
       This is a list:
          A Element A
          C Element C
          F Element F
          J Element J
       Sorry, no list today.


Expected results: only the .ie part should be included:
       This is a list:
          A Element A
          C Element C
          F Element F
          J Element J


Additional info:
Comment 1 Rene Uittenbogaard 2003-06-30 17:30:35 EDT
Created attachment 92698 [details]
example mm source code document to reproduce the problem
Comment 2 Thomas Woerner 2004-08-17 05:42:23 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.