Bug 983102 - Tracker bug - If the home directory entry is empty, then its not a valid OpenShift user.
Tracker bug - If the home directory entry is empty, then its not a valid Open...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 09:53 EDT by chris alfonso
Modified: 2017-03-08 12 EST (History)
6 users (show)

See Also:
Fixed In Version: pam_openshift-1.6.3-1
Doc Type: Bug Fix
Doc Text:
An exception was triggered in pam_openshift if a user's home directory was empty, preventing users from logging in. With this fix, empty home directories are ignored and users are able to log in.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:19:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris alfonso 2013-07-10 09:53:42 EDT
Description of problem:
We need to pull in commit a4a84c493c78d3751d20e47e25423cfcfde19e88 from origin-server to fix this.
Comment 2 Miciah Dashiel Butler Masters 2013-07-10 10:37:26 EDT
Which commit? I can't find a commit with that ID—https://github.com/openshift/origin-server/commit/a4a84c493c78d3751d20e47e25423cfcfde19e88 gives a 404.
Comment 3 chris alfonso 2013-07-10 10:42:01 EDT
My mistake, the commit in origin-server is 8a41b266c6877f8c25a82b518e947d467421de1a
Comment 5 Gaoyun Pei 2013-07-16 02:01:09 EDT
Checked the source code of package pam_openshift-1.6.3-1, the code metioned in commit 8a41b266c6877f8c25a82b518e947d467421de1a has been merged into this package.

And the pam_openshift package on this puddle:
[root@node ~]# rpm -qa|grep pam_openshift
pam_openshift-1.6.3-1.el6op.x86_64

so verify this bug on puddle 2013-07-12
Comment 8 errata-xmlrpc 2013-08-05 13:19:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.