Bug 983113 - Conky fails to start.
Conky fails to start.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: conky (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 10:15 EDT by Jakub Ruzicka
Modified: 2013-07-10 10:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 10:21:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Ruzicka 2013-07-10 10:15:45 EDT
Description of problem:
Conky can't start because it can't find liblua5.1.so.0.

$ conky
conky: error while loading shared libraries: liblua5.1.so.0: cannot open shared object file: No such file or directory

Version-Release number of selected component (if applicable):
conky-1.9.0-4.20121101gitbfaa84.fc19.x86_64

How reproducible:
Just run conky.

Steps to Reproduce:
1. run `conky`

Actual results:
conky: error while loading shared libraries: liblua5.1.so.0: cannot open shared object file: No such file or directory

Expected results:
conky starts

Additional info:
$ rpm -q lua
lua-5.1.4-12.fc19.x86_64

$ rpm -ql lua | grep .so
/usr/lib64/liblua-5.1.so

After symlinking the lib, it doesn't complain but still doesn't work:
# cd /usr/lib64
# ln -s liblua-5.1.so liblua5.1.so.0
$ conky
Conky: can't open display: :0
Comment 1 Jakub Ruzicka 2013-07-10 10:21:33 EDT
I'm sorry, local binary was interfering.

Note You need to log in before you can comment on or make changes to this bug.