Bug 983139 - [RFE] cinder: allow restore of volume from its snapshot
[RFE] cinder: allow restore of volume from its snapshot
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Maint
Haim
storage
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 11:32 EDT by Dafna Ron
Modified: 2016-04-26 15:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: restore snapshot into volume Reason: Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 03:19:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1262656 None None None Never

  None (edit)
Description Dafna Ron 2013-07-10 11:32:46 EDT
Description of problem:

currently we can take a snapshot from a volume which is a read only snapshot and can only be used to create new volumes. 
I think that we should allow restore of the original volume from the snapshot. 

Version-Release number of selected component (if applicable):

openstack-cinder-2013.1.2-3.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a volume 
2. create a snapshot
3. 

Actual results:

there is no option for restore of original volume from the snapshot

Expected results:

we should be able to restore the original volume 

Additional info:
Comment 1 Eric Harney 2013-07-10 11:37:00 EDT
The supported method to do this is to call "cinder create --snapshot-id <id> <size>" which will generate a new volume from the snapshot.   Restores are not done to the original volume.  (i.e. there is no "revert to snapshot" operation)
Comment 2 Dafna Ron 2013-07-10 11:49:26 EDT
(In reply to Eric Harney from comment #1)
> The supported method to do this is to call "cinder create --snapshot-id <id>
> <size>" which will generate a new volume from the snapshot.   Restores are
> not done to the original volume.  (i.e. there is no "revert to snapshot"
> operation)

yes, I know that this is how it works right now. 
I think that its a bug that we cannot restore from the snapshot. 
we can move to RFE if you think that this needs a large implementation or design change
Comment 3 Eric Harney 2013-08-07 13:08:37 EDT
My primary concern around this is that I'm not sure it's possible for all Cinder drivers, as different drivers have different concepts of the relationship between a volume and a snapshot and how they are related on the storage backend.  As such, upstream would likely reject this based on it breaking consistency for behavior of operations across different configurations.
Comment 7 Summer Long 2014-07-23 01:28:33 EDT
Eric, I'm moving requires_doc_text to - since nothing was done. Unless you you want to set it as a Known Issue with text? (Release notes are regenerated with each maintenance release if you want to include info.)

Note You need to log in before you can comment on or make changes to this bug.