Bug 983285 - netcdf.mod unusable because it was compiled by a different version of GNU Fortran
netcdf.mod unusable because it was compiled by a different version of GNU For...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: netcdf-fortran (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 17:15 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2013-07-27 21:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: netcdf-fortran-4.2-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:08:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2013-07-10 17:15:55 EDT
Description of problem:
netcdf.mod cannot be included in Fortran code because the compiler complains it was compiled by a different version of GNU Fortran.

Version-Release number of selected component (if applicable):
netcdf-fortran-4.2-6.fc19.x86_64
gcc-gfortran-4.8.1-1.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. cat > test_nc_mod.f90 << EOF
program nc_test
   use netcdf
end program nc_test
EOF
2. gfortran -I/usr/lib64/gfortran/modules test_nc_mod.f90 -L/usr/lib64 -lnetcdf -lnetcdff -o a.out
3.

Actual results:
test_nc_mod.f90:2.7:

   use netcdf
       1
Fatal Error: Cannot read module file 'netcdf.mod' opened at (1), because it was created by a different version of GNU Fortran

Expected results:
Successful compilation.

Additional info:
It looks like it was built with gcc-gfortran-4.7.2-7.fc19.x86_64, so a simple rebuild should resolve this.
Comment 1 Dominik 'Rathann' Mierzejewski 2013-07-10 17:22:59 EDT
I tried rebuilding 4.2-8.fc20 from koji in local f19 mock, but some regtests are failing with segfaults:

FAIL: run_f90_par_test.sh
FAIL: run_f77_par_test.sh
Comment 2 Fedora Update System 2013-07-19 17:46:04 EDT
netcdf-fortran-4.2-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/netcdf-fortran-4.2-8.fc19
Comment 3 Fedora Update System 2013-07-20 05:45:17 EDT
Package netcdf-fortran-4.2-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing netcdf-fortran-4.2-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13274/netcdf-fortran-4.2-8.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-27 21:08:30 EDT
netcdf-fortran-4.2-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.