Bug 983322 - org.apache.commons.configuration missing dependency on org.apache.commons.beanutils
org.apache.commons.configuration missing dependency on org.apache.commons.bea...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: EAP 6.1.1
Assigned To: Paul Gier
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 20:39 EDT by James Livingston
Modified: 2016-02-21 19:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of Red Hat JBoss Enterprise Application Platform 6, the org.apache.commons.configuration module did not declare a dependency on the org.apache.commons.beanutils module. This caused a Configuration class to throw a ClassNotFoundException due to a missing BeanUtils class when certain code paths were used. This release of the product has the dependency added to org.apache.commons.configuration so the code no longer throws a ClassNotFoundException.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1671 Major Resolved org.apache.commons.configuration missing dependency on org.apache.commons.beanutils 2016-02-06 09:17 EST

  None (edit)
Description James Livingston 2013-07-10 20:39:14 EDT
Apache commons configuration uses commons bean-utils in a few places, but the module.xml does not declare a dependency on it.

The POM (http://search.maven.org/#artifactdetails|commons-configuration|commons-configuration|1.6|jar) also suggests that digesters is also a dependency, but I haven't seen any issues from that being missing.
Comment 2 JBoss JIRA Server 2013-07-15 05:50:28 EDT
jaikiran pai <jpai@redhat.com> made a comment on jira WFLY-1671

The linked PR has been merged.
Comment 3 Nikoleta Ziakova 2013-08-06 08:55:09 EDT
In EAP 6.1.1. ER4 apache commons configuration has declared dependency on org.apache.commons.beanutils. However there is still dependency on commons-digester in pom file. Should this be removed or not?
Comment 4 Paul Gier 2013-08-11 14:26:00 EDT
> However there is still dependency on commons-digester in pom file. Should this be removed or not?

I don't think the pom and module.xml necessarily need to match.  The module dependencies are more limited in scope and only need to cover supported use cases.  Whereas the pom dependency actually effects compile classpath during the build.  So I think it's ok to leave the pom the way it is currently.
Comment 5 Scott Mumford 2013-08-11 19:03:03 EDT
Added prose-form of the release note content provided by jlivings. 

Original text included below for reference:

> Cause: The org.apache.commons.configuration module did not declare a dependency on the org.apache.commons.beanutils module.
> Consequence: If certain code paths were used, a Configuration class would throw a ClassNotFoundException due to a missing BeanUtils class.
> Fix: Add the dependency to org.apache.commons.configuration.
> Result: The code no longer throws a ClassNotFoundException.

Setting Requires Docs Text flag to '+'. 
Please comment and reset to '?' if there is an error in the new note.
Comment 6 Nikoleta Ziakova 2013-08-12 06:48:44 EDT
I will verify this issue based on previous comments.
Comment 7 Nikoleta Ziakova 2013-08-12 06:49:01 EDT
Verified for EAP 6.1.1 ER4

Note You need to log in before you can comment on or make changes to this bug.