Bug 983328 - [abrt] system-config-printer-1.4.1-6.fc19: newprinter.py:2628:on_tvNPDevices_cursor_changed:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 8: ordinal not in range(128)
[abrt] system-config-printer-1.4.1-6.fc19: newprinter.py:2628:on_tvNPDevices_...
Status: CLOSED DUPLICATE of bug 971973
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:b2df149e7318b8d745f99461346...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 21:53 EDT by xiuyuan021
Modified: 2013-07-11 03:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 03:10:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (974 bytes, text/plain)
2013-07-10 21:53 EDT, xiuyuan021
no flags Details
File: environ (1.39 KB, text/plain)
2013-07-10 21:53 EDT, xiuyuan021
no flags Details

  None (edit)
Description xiuyuan021 2013-07-10 21:53:21 EDT
Version-Release number of selected component:
system-config-printer-1.4.1-6.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
core_backtrace: 104d87ae486e7a62707cf7fa038cb9db876384b4 0xa44 on_tvNPDevices_cursor_changed /usr/share/system-config-printer/newprinter.py -
dso_list:       system-config-printer-libs-1.4.1-6.fc19.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
newprinter.py:2628:on_tvNPDevices_cursor_changed:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 8: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 2628, in on_tvNPDevices_cursor_changed
    device.menuentry = _("LPD/LPR queue '%s'") % queue
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 8: ordinal not in range(128)

Local variables in innermost frame:
widget: <TreeView object at 0x28f7a00 (GtkTreeView at 0x25a8040)>
column: <TreeViewColumn object at 0x2f62a00 (GtkTreeViewColumn at 0x2b41c40)>
self: <NewPrinterGUI object at 0x28f7500 (newprinter+NewPrinterGUI at 0x263d000)>
rest: None
physicaldevice: <PhysicalDevice.PhysicalDevice (,,)>
queue: u'lpd'
iter: <GtkTreeIter at 0x34e48a0>
hostport: None
device: <cupshelpers.Device "lpd">
path: <GtkTreePath at 0x2e16900>
model: <TreeStore object at 0x32ef910 (GtkTreeStore at 0x2cc0c20)>
scheme: None
Comment 1 xiuyuan021 2013-07-10 21:53:28 EDT
Created attachment 771924 [details]
File: backtrace
Comment 2 xiuyuan021 2013-07-10 21:53:33 EDT
Created attachment 771925 [details]
File: environ
Comment 3 Jiri Popelka 2013-07-11 03:10:17 EDT

*** This bug has been marked as a duplicate of bug 971973 ***

Note You need to log in before you can comment on or make changes to this bug.