Bug 983339 - Some gears are down when creating scalable app with a large number of gears
Some gears are down when creating scalable app with a large number of gears
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 23:06 EDT by Nan Wei
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 07:52:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nan Wei 2013-07-10 23:06:48 EDT
Description of problem:
After creating a scalable app with the large number gears, check https://url/haproxy-status, found that some gears are down.

Version-Release number of selected component (if applicable):
OSE-1.2 RHN Stage

How reproducible:
always

Steps to Reproduce:
1.create a scale app
  rhc app-create phps php-5.3 -s
2.set cartridge scale number
  rhc cartridge scale php-5.3 -a phps --min 20
3.check haproxy-status
  https://url/haproxy-status

Actual results:
Wait for 10 minutes. Only the first 10 gears are active, the others are down.

[weinan@dhcp-65-25 ~]$ rhc app-show test -l nanwei --gears
ID                       State   Cartridges          Size  SSH URL
------------------------ ------- ------------------- ----- ----------------------------------------------------------------------
51dd2a656e0f5d100400084f started php-5.3 haproxy-1.4 small 51dd2a656e0f5d100400084f@test-nanwei.osetestv2.com
51dd2ab66e0f5d1004000870 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000870@51dd2ab66e0f5d1004000870-nanwei.osetestv2.com
51dd2ab66e0f5d1004000871 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000871@51dd2ab66e0f5d1004000871-nanwei.osetestv2.com
51dd2ab66e0f5d1004000872 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000872@51dd2ab66e0f5d1004000872-nanwei.osetestv2.com
51dd2ab66e0f5d1004000873 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000873@51dd2ab66e0f5d1004000873-nanwei.osetestv2.com
51dd2ab66e0f5d1004000874 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000874@51dd2ab66e0f5d1004000874-nanwei.osetestv2.com
51dd2ab66e0f5d1004000875 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000875@51dd2ab66e0f5d1004000875-nanwei.osetestv2.com
51dd2ab66e0f5d1004000876 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000876@51dd2ab66e0f5d1004000876-nanwei.osetestv2.com
51dd2ab66e0f5d1004000877 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000877@51dd2ab66e0f5d1004000877-nanwei.osetestv2.com
51dd2ab66e0f5d1004000878 started php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000878@51dd2ab66e0f5d1004000878-nanwei.osetestv2.com
51dd2ab66e0f5d1004000879 new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000879@51dd2ab66e0f5d1004000879-nanwei.osetestv2.com
51dd2ab66e0f5d100400087a new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087a@51dd2ab66e0f5d100400087a-nanwei.osetestv2.com
51dd2ab66e0f5d100400087b new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087b@51dd2ab66e0f5d100400087b-nanwei.osetestv2.com
51dd2ab66e0f5d100400087c new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087c@51dd2ab66e0f5d100400087c-nanwei.osetestv2.com
51dd2ab66e0f5d100400087d new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087d@51dd2ab66e0f5d100400087d-nanwei.osetestv2.com
51dd2ab66e0f5d100400087e new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087e@51dd2ab66e0f5d100400087e-nanwei.osetestv2.com
51dd2ab66e0f5d100400087f new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d100400087f@51dd2ab66e0f5d100400087f-nanwei.osetestv2.com
51dd2ab66e0f5d1004000880 new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000880@51dd2ab66e0f5d1004000880-nanwei.osetestv2.com
51dd2ab66e0f5d1004000881 new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000881@51dd2ab66e0f5d1004000881-nanwei.osetestv2.com
51dd2ab66e0f5d1004000882 new     php-5.3 haproxy-1.4 small 51dd2ab66e0f5d1004000882@51dd2ab66e0f5d1004000882-nanwei.osetestv2.com


Expected results:
20 gears are active.

Additional info:
Comment 2 Brenton Leanhardt 2013-08-15 10:27:24 EDT
Does this still happen in Online with the recent changes they have shipped?
Comment 3 Luke Meyer 2013-09-05 10:43:25 EDT
Follow up on needinfo
Comment 4 Nan Wei 2013-09-27 06:15:37 EDT
It doesn't happen in online when create a scale php-5.3 app and set --min 20. 
20 gears are active.
Sorry, I just find your needinfo request and sorry for this if it is due to my miss.
Comment 5 Brenton Leanhardt 2013-09-27 07:52:46 EDT
Thanks, we'll close this as DEFERRED and pick it up during the next rebase.

Note You need to log in before you can comment on or make changes to this bug.