This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983362 - Metadata locks, data locks in replicate should be in different domains
Metadata locks, data locks in replicate should be in different domains
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 986162
  Show dependency treegraph
 
Reported: 2013-07-11 01:25 EDT by Pranith Kumar K
Modified: 2013-09-23 01:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 986162 (view as bug list)
Environment:
Last Closed: 2013-09-23 01:54:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-07-11 01:25:14 EDT
Description of problem:

Ranges of data full file lock and meta-data lock overlap because
    of which metadata transactions wait for data transactions to
    unlock inodelk which are causing un-necessary delays

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-07-11 01:27:55 EDT
REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-07-11 06:15:15 EDT
REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Anand Avati 2013-07-12 08:15:03 EDT
REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Anand Avati 2013-07-22 13:00:46 EDT
REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Anand Avati 2013-08-02 08:57:38 EDT
REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Pranith Kumar K 2013-09-23 01:54:05 EDT
This lock conversion of moving metadata locks into different domain is added to locks xlator itself to make sure it is backward compatible as part of 993981. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.