Bug 9834 - problem with /etc/rc.d/init.d/autofs
problem with /etc/rc.d/init.d/autofs
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-28 11:16 EST by Prahlad
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-01 11:48:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prahlad 2000-02-28 11:16:30 EST
There is a bug in /etc/rc.d/init.d/autofs with "reload" or "restart". The
older automount processes will not get killed.

The problem seems to be in line 149,

                if ! grep -q "^$command" $TMP2; then

Here, $TMP2 ought to be $TMP1.

Also "^$command" ought to be "^$command$" or something like that to check
for new options added to the end of the line in the auto.master file.
Comment 1 Nalin Dahyabhai 2000-03-01 11:48:59 EST
The first item looks correct; we'll incorporate it into autofs-3.1.4-5 and
later.  You might want to bounce this to the autofs mailing list
(autofs@linux.kernel.org), which goes to the authors of the codebase that
all distributions use.

Note You need to log in before you can comment on or make changes to this bug.