Bug 983424 - mc sftp link ignores .ssh/config settings
mc sftp link ignores .ssh/config settings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 04:02 EDT by Jan ONDREJ
Modified: 2014-01-10 13:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-10 13:41:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2013-07-11 04:02:16 EDT
Description of problem:
mc's sftp link can't open .ssh/config settings.

Version-Release number of selected component (if applicable):
mc-4.8.7-3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. cat << EOF >> ~/.ssh/config
Host mytest.localhost
  HostName 127.0.0.1
EOF
2. run mc, open sftp link to: mytest.localhost

Actual results:
Cannot chdir to "/sftp://mytest.localhost"

Additional info:
strace shows, that ~ expansion fails:
open("/home/ondrejj/~/.ssh/config", O_RDONLY) = -1 ENOENT (No such file or direc
tory)

Workaround:
ln -s ~ '~'
Comment 1 Jan ONDREJ 2014-01-10 13:41:51 EST
Unable to reproduce with:
mc-4.8.11-1.fc20.x86_64
Looks like this is already fixed. Closing.
Thanks for fix.

Note You need to log in before you can comment on or make changes to this bug.