Bug 983429 - Text in selects in new dashbuilder branding is not fully displayed
Text in selects in new dashbuilder branding is not fully displayed
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: Neus Miras
Jan Hrcek
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 04:18 EDT by Jan Hrcek
Modified: 2014-08-06 16:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Text in selects (200.08 KB, image/png)
2013-07-11 04:18 EDT, Jan Hrcek
no flags Details
Updated envelope (11.26 KB, application/zip)
2013-08-29 06:00 EDT, Pedro Zapata
no flags Details
Updated skin (18.02 KB, application/zip)
2013-08-29 06:00 EDT, Pedro Zapata
no flags Details
Issue still present in ER3 - see screenshot (141.38 KB, image/png)
2013-09-13 07:57 EDT, Jan Hrcek
no flags Details
Problem appeared again in ER5 (150.54 KB, image/png)
2013-11-29 00:56 EST, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-07-11 04:18:40 EDT
Created attachment 772069 [details]
Text in selects

Description of problem:
The bug title says it all :)
See screenshot. The problem is very noticable in Firefox. It is not as visible in Google Chrome, but it is still quite annoying.


Version-Release number of selected component (if applicable):
6.0.0.DR6

How reproducible:
Always in my environment (Fedora 19, Browsers: Firefox 22, Google chrome 28)

Steps to Reproduce:

1. Start dashbuilder and login with admin.
2. Navigate for example to workspace Showcase, page Sales Opportunities; Or go to General Configuration > Workspaces

Actual results:
The text in selects is not fully visible. This effect is very noticable on Firefox, less noticable (but still present) in Chrome.

Expected results:
The text in select should be fully visible.
Comment 1 David Gutierrez 2013-07-12 04:29:34 EDT
This was a problem present in the first versions of the Dashbuilder RH branding. The latest one sent to the productization team fixed that. So I guess you are testing an out-of-date version. A couple of questions:

1.- Where did you get the branding assets?
2.- Did you forked the dashbuilder on a private git repo? If so, may I have access to it.
Comment 2 Jan Hrcek 2013-07-13 01:44:50 EDT
I'm not sure if prod team sees this, so adding "needinfo" to be sure.
Comment 4 Jan Hrcek 2013-08-15 08:49:10 EDT
I just tested with BPMS 6.0.0.ER1 - the issue is still present. Is this really an issue with prod incorrectly applying branding, or is there an issue with the branding itself?
Comment 5 Jan Hrcek 2013-08-29 03:14:55 EDT
Not sure, if anyone is looking into this issue anymore, but the problem is still present in BPMS 6.0.0.ER2
Comment 6 Pedro Zapata 2013-08-29 06:00:05 EDT
Created attachment 791673 [details]
Updated envelope
Comment 7 Pedro Zapata 2013-08-29 06:00:55 EDT
Created attachment 791674 [details]
Updated skin
Comment 8 Pedro Zapata 2013-08-29 06:08:03 EDT
The attached files must be updated in the private product branch to apply updated branding to the following paths:

Default_Envelope.zip in:

dashboard-builder/modules/dashboard-ui/dashboard-ui-resources/src/main/webapp/WEB-INF/etc/envelopes 

Default_Skin.zip in: 

dashboard-builder/modules/dashboard-ui/dashboard-ui-resources/src/main/webapp/WEB-INF/etc/skins

Please, contact Neus (nmirasch@redhat.com) for any support regarding this.

We can't commit directly to the private product branch.
Comment 9 Jan Hrcek 2013-09-13 07:56:57 EDT
The issue is still present in BPMS ER3.
Comment 10 Jan Hrcek 2013-09-13 07:57:44 EDT
Created attachment 797307 [details]
Issue still present in ER3 - see screenshot
Comment 11 Neus Miras 2013-09-13 11:33:06 EDT
I have done a pull request 

https://github.com/jboss-integration/dashboard-builder/pull/2

To include he skin and envelope changes tha solves the style visualization.
Comment 15 Jan Hrcek 2013-10-17 01:31:33 EDT
Ok, verified with BPMS 6.0.0 ER4
Comment 16 Jan Hrcek 2013-11-29 00:56:26 EST
I'm afraid we have a regression. The problem appeared again in ER5 - I attach a screenshot of how it currently looks.
The environment in the screenshot attached is: BPMS 6.0.0 ER5 deployed on EAP 6.1.1, browser firefox 17
Comment 17 Jan Hrcek 2013-11-29 00:56:55 EST
Created attachment 830480 [details]
Problem appeared again in ER5
Comment 18 Pedro Zapata 2013-11-29 03:50:10 EST
I have tested with Firefox and Chrome in a ER5 installation @ http://hp-dl380pg8-01.lab.eng.brq.redhat.com:8170/business-central/ 

and everything looks fine to me, at least in one of my laptops. I have tested with Firefox 23 and Chrome 31 with Fedora.

- Have you tried to delete browser cache to force CSS reload?
- Can you please confirm if that happens with any browser?
- Can you please try to login into the system above and see if you can see the error there?
Comment 19 Jan Hrcek 2013-11-29 04:25:45 EST
Pedro I tried with the installation above and I still see the problem in my browser. I believe it will be primarily caused by Firefox 17 (Extended Support Version, that is distributed as a part of RHEL 6). 

I also clened my browser cache and my zoom level is default (100%).

When trying with other browsers (chrome) it works correctly.
Comment 20 Jan Hrcek 2013-11-29 05:32:15 EST
I checked with several of my colleagues and the results are:
1) Firefox 25 + Fedora 19 -> worked CORRECTLY
2) Firefox 18 + Fedora 16 -> issue PRESENT
3) Firefox 17 + Fedora 19 -> issue PRESENT
4) Firefox 17 + Fedora 19 -> issue PRESENT

So in the end it seems it might be issue specific only to combination of Fedora and firefox. Since Fedora is not supported, I will check if it works correctly on supported platforms and will close this issue.
Comment 21 Pedro Zapata 2013-12-03 04:59:28 EST
Can you please confirm whether this BZ can be closed or need further review?
Comment 22 Jan Hrcek 2013-12-03 07:12:29 EST
I am sorry, for raising false alarm. In the end it turned out, that on operating systems targeted by PRD the text in selects is displayed correctly after all.

The issue seems to be only present when using firefox (older versions like 17,18) on Fedora, which, based on PRD, is NOT to be supported. Most likely it will be caused by some font issue. So I guess there is currently no more action needed from the engineering -> setting status back to verified again.

Note You need to log in before you can comment on or make changes to this bug.