Bug 983430 - openmpi module does not properly set MANPATH
openmpi module does not properly set MANPATH
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openmpi (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Michal Schmidt
zguo
:
Depends On:
Blocks: 1172231 1269638 1270066
  Show dependency treegraph
 
Reported: 2013-07-11 04:19 EDT by Tru Huynh
Modified: 2016-01-20 14:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 14:21:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 6551 None None None Never

  None (edit)
Description Tru Huynh 2013-07-11 04:19:08 EDT
Description of problem:
openmpi module definition MANPATH prepend missing 

Version-Release number of selected component (if applicable):
openmpi-1.5.4-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum install openmpi
2. module load openmpi-x86_64
3. man mpirun

Actual results:
"No manual entry for mpirun"

Expected results:
man page display

Additional info:
Comment 2 Tru Huynh 2013-07-11 04:40:20 EDT
relates for BZ 786201
Comment 3 RHEL Product and Program Management 2013-10-13 23:10:19 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Tru Huynh 2014-02-27 17:09:54 EST
not fixed with openmpi-1.5.4-2.el6.x86_64

$ rpm -ql openmpi| grep modulefiles
/etc/modulefiles/openmpi-x86_64
$ rpm -ql mpich2| grep modulefiles
/usr/share/Modules/modulefiles/mpich2-x86_64

environment-modules-3.2.9c-6.el6.x86_64 is defining
MODULESHOME as /usr/share/Modules while openmpi module file is expecting it at /etc...
Comment 6 Michal Schmidt 2016-01-20 14:21:39 EST
MANPATH was added to the module file in openmpi-1.8.1-1 in RHEL 6.6.
I have now added it also to compat-openmpi while rewriting its spec file for RHEL 6.8 for bug 1158864.
Closing this BZ, because the openmpi package is already fixed.

Note You need to log in before you can comment on or make changes to this bug.