This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983455 - No possibility to create a repository within any group via REST API
No possibility to create a repository within any group via REST API
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mark Proctor
Ivo Bek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 05:17 EDT by Ivo Bek
Modified: 2014-08-06 16:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-07-11 05:17:42 EDT
Description of problem:

If you look at this entity https://github.com/droolsjbpm/kie-wb-common/blob/master/kie-wb-common-services/kie-wb-common-services-api/src/main/java/org/kie/workbench/common/services/shared/rest/Repository.java  ... there is no way how to set a group for the repository via REST API, so the created repository cannot be used in business central then because it seems almost invisible. For example it's not possible to build and deploy a project from the repository which is not in any group.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marek Baluch 2013-07-11 11:32:47 EDT
This issue prevents automation of cluster and other jobs there for it is considered a test blocker.
Comment 2 Marco Rietveld 2013-07-12 07:18:15 EDT
Hi Ivo, 

Currently, you can create and administer the repository via both via the UI and the new CLI (command line interface). 

Why do you think the REST api should also have this option? 

Thanks.
Comment 4 Marco Rietveld 2013-07-12 08:01:30 EDT
Nevermind, this is the business-central REST api, not the exec-server one. Reassigning to Jervis.
Comment 5 manstis 2013-07-15 06:01:55 EDT
Jervis, please could you have a look (Repositories need to be assigned a Group in order for them to operate correctly in kie-wb. The hierarchy of artifacts is: Group--[1..n]-->Repository--[1..n]-->Project), Thanks, Mike
Comment 6 Marek Baluch 2013-07-18 02:34:21 EDT
Again the stability and reliability of server interfaces is very important for further testing on ExecutionServer, Clustering and Performance.
Comment 9 Jervis Liu 2013-07-23 07:47:35 EDT
Fixed
Comment 10 Lukáš Petrovický 2013-07-23 08:16:16 EDT
(In reply to Jervis Liu from comment #9)
> Fixed

Please do not forget to move fixed issues to MODIFIED.
Comment 11 Ivo Bek 2013-09-09 04:54:09 EDT
Well, now it's possible to add the previously created repository to any group via REST API and it works in BPMS 6.0.0.ER2, so I mark it as verified.

Note You need to log in before you can comment on or make changes to this bug.