Bug 983473 - Actions button for network not present
Actions button for network not present
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
x86_64 Linux
unspecified Severity low
: ---
: 4.0
Assigned To: Julie Pichon
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 05:53 EDT by Jaroslav Henner
Modified: 2015-06-04 17:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 11:03:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User context (100.93 KB, image/png)
2013-07-22 03:47 EDT, Jaroslav Henner
no flags Details
Admin context (114.73 KB, image/png)
2013-07-22 03:49 EDT, Jaroslav Henner
no flags Details

  None (edit)
Description Jaroslav Henner 2013-07-11 05:53:48 EDT
Description of problem:
There are no action buttons on 
https://controller.rhos/dashboard/project/networks/

Version-Release number of selected component (if applicable):
python-django-horizon.noarch          2013.1.2-2.el6ost     @puddle             


How reproducible:
1/1

Steps to Reproduce:
1. Create a network
2.
3.

Actual results:
no per-network action button but checkboxes actions present

Expected results:
buttons

Additional info:
Comment 2 Julie Pichon 2013-07-16 11:05:52 EDT
Could you provide a screenshot?

I wonder if this may be due to the network being shared but owned by another user (e.g. Admin). Could you confirm? I can't otherwise reproduce, if I create a network in the current project I do see action buttons.
Comment 3 Jaroslav Henner 2013-07-22 03:47:04 EDT
Created attachment 776783 [details]
User context
Comment 4 Jaroslav Henner 2013-07-22 03:49:41 EDT
Created attachment 776784 [details]
Admin context

It looks like in Admin context, the buttons are always visible. In user context, they are visible only for non-shared networks, no matter who owns the network. You can create a shared network using:

quantum net-create foo --shared

I didn't find a way to create it in Horizon. I can only set it as shared after creation. This may be another bug.
Comment 5 Julie Pichon 2013-10-21 11:03:22 EDT
Quantum/Neutron's default policy only allows Admins to create and update Shared networks, Horizon is reflecting the default policy at the moment (dynamic RBAC is a work in progress that'll take several cycles to smooth out). Like on the CLI, only admins can create a Shared network via Horizon, using the Admin Networks panel.

$ neutron net-create foo --shared
{"NeutronError": {"message": "Policy doesn't allow create_network to be performed.", "type": "PolicyNotAuthorized", "detail": ""}}

I'll also update bug 948313 for the "visible checkboxes" part of the bug.

Note You need to log in before you can comment on or make changes to this bug.