Bug 983477 - Provide option to use/not use kernel-readdirp
Provide option to use/not use kernel-readdirp
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 987748
  Show dependency treegraph
 
Reported: 2013-07-11 05:54 EDT by Pranith Kumar K
Modified: 2014-04-17 07:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 987748 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:43:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-07-11 05:54:41 EDT
Description of problem:
    By default fuse kernel readdirp usage in fuse xlator should be off.
    When mount option use-readdirp=yes is provided it should use
    fuse-kernel's readdirp.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-07-11 05:56:01 EDT
REVIEW: http://review.gluster.org/5322 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-07-11 05:58:28 EDT
REVIEW: http://review.gluster.org/5323 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#1) for review on release-3.4 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Anand Avati 2013-07-11 09:35:51 EDT
REVIEW: http://review.gluster.org/5322 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Anand Avati 2013-07-11 09:38:50 EDT
REVIEW: http://review.gluster.org/5323 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#2) for review on release-3.4 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Anand Avati 2013-07-12 10:36:42 EDT
COMMIT: http://review.gluster.org/5322 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 61b09562b934b53dadcd566f6feb72301097933c
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 11 12:52:11 2013 +0530

    mount/fuse: Provide option to use/not use kernel-readdirp
    
    By default fuse kernel readdirp usage in fuse xlator is off.
    When mount option use-readdirp=yes is provided it starts using
    fuse-kernel's readdirp.
    
    Change-Id: Id37edc53b1adc1638186d956c2f74c1e4e48aa59
    BUG: 983477
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5322
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Anand Avati 2013-07-12 13:30:38 EDT
COMMIT: http://review.gluster.org/5323 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit b92b98ef9a2d912273aeb29a82ffd25831a8eec3
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 11 12:52:11 2013 +0530

    mount/fuse: Provide option to use/not use kernel-readdirp
    
    By default fuse kernel readdirp usage in fuse xlator is off.
    When mount option use-readdirp=yes is provided it starts using
    fuse-kernel's readdirp.
    
    BUG: 983477
    Change-Id: Ibdaf1407d6f2a782a4a1916fad374f36fca6c5e7
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5323
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Anand Avati 2013-09-09 06:14:25 EDT
REVIEW: http://review.gluster.org/5851 (glusterfsd: use-readdirp w/o arguments should not turn off readdirp) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 8 Anand Avati 2013-09-09 21:28:53 EDT
REVIEW: http://review.gluster.org/5851 (glusterfsd: use-readdirp w/o arguments should not turn off readdirp) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 9 Anand Avati 2013-09-10 00:42:24 EDT
COMMIT: http://review.gluster.org/5851 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1f7469164a8d8fb0e031078073465b59c4334752
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Mon Sep 9 03:08:08 2013 -0700

    glusterfsd: use-readdirp w/o arguments should not turn off readdirp
    
    `use-readdirp` has an optional argument in argp -
    specifying just `--use-readdirp` command line should not
    'turn off' readdirp, since that undermines the meaning
    of such an argument.
    
    Change-Id: I965d87e29bd0d61997d9be96fa698e270a2ee173
    BUG: 983477
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/5851
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 10 Niels de Vos 2014-04-17 07:43:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.