Bug 983491 - Remove DATA storage domains ISCSI/FCP fail on vdsm 3.3
Remove DATA storage domains ISCSI/FCP fail on vdsm 3.3
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity unspecified
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Leonid Natapov
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 06:16 EDT by Ohad Basan
Modified: 2016-02-10 12:38 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 07:32:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-07-11 06:16:47 EDT
Description of problem:
running engine 3.3 (sha 3b106b7c0102f3125e5099b99bec1dddc2f6cf27)
and vdsm-4.11.0-121.git082925a.el6.x86_64

sending a rest query to remove storage domains fails with

hread-343::DEBUG::2013-07-11 11:00:12,475::lvm::310::Storage.Misc.excCmd::(cmd) FAILED: <err> = '  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  device-mapper: remove ioctl on  failed: Device or resource busy\n  Unable to deactivate c7bf8bca--3a0c--4cd7--9f25--f0b35f4535fc-ids (253:49)\n  Unable to deactivate logical volume "ids"\n'; <rc> = 5
Thread-343::DEBUG::2013-07-11 11:00:12,489::lvm::476::OperationMutex::(_invalidatepvs) Operation 'lvm invalidate operation' got the operation mutex
Thread-343::DEBUG::2013-07-11 11:00:12,489::lvm::479::OperationMutex::(_invalidatepvs) Operation 'lvm invalidate operation' released the operation mutex
Thread-343::DEBUG::2013-07-11 11:00:12,490::lvm::488::OperationMutex::(_invalidatevgs) Operation 'lvm invalidate operation' got the operation mutex
Thread-343::DEBUG::2013-07-11 11:00:12,490::lvm::490::OperationMutex::(_invalidatevgs) Operation 'lvm invalidate operation' released the operation mutex
Thread-343::ERROR::2013-07-11 11:00:12,490::task::850::TaskManager.Task::(_setError) Task=`62354b77-0af1-479c-833c-b74893c8a318`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 2621, in formatStorageDomain
    self._recycle(sd)
  File "/usr/share/vdsm/storage/hsm.py", line 2567, in _recycle
    dom.format(dom.sdUUID)
  File "/usr/share/vdsm/storage/blockSD.py", line 888, in format
    lvm.removeVG(sdUUID)
  File "/usr/share/vdsm/storage/lvm.py", line 897, in removeVG
    raise se.VolumeGroupRemoveError("VG %s remove failed." % vgName)
VolumeGroupRemoveError: Volume Group remove error: ('VG c7bf8bca-3a0c-4cd7-9f25-f0b35f4535fc remove failed.',)

although it says that the device is locked,
I suspect that it is a bug because the same command flow works successfully on vdsm 3.2 using the same engine rpms
Comment 4 Ayal Baron 2013-07-15 10:27:23 EDT
remove VG is failing because the IDS LV is open.
Is sanlock not deactivated on this domain?

Note You need to log in before you can comment on or make changes to this bug.