Bug 983503 - [TestOnly] After migration w/ all devices over pci-bridge under pci-bridge, guest hang.
[TestOnly] After migration w/ all devices over pci-bridge under pci-bridge, g...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Marcel Apfelbaum
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 06:41 EDT by Qian Guo
Modified: 2014-06-17 23:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:16:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Guo 2013-07-11 06:41:31 EDT
Description of problem:
Launch guest w/ devices over pci-bridge under pci-bridge, after migration, guest hangs, and after "system_reset", guest reboot successfully.
Have tested w/o pci-bridge, not hit this issue.

Version-Release number of selected component (if applicable):
# uname -r
3.10.0-0.rc7.64.el7.x86_64
# rpm -q qemu-kvm
qemu-kvm-1.5.1-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot src guest and dst guest like below command:

#/usr/libexec/qemu-kvm -M pc -device pci-bridge,id=bridge1,chassis_nr=1 -device pci-bridge,id=bridge2,bus=bridge1,addr=0x2,chassis_nr=1 -cpu Penryn -m 4G -smp 4,sockets=1,cores=4,threads=1 -enable-kvm -nodefaults -nodefconfig -monitor stdio -boot menu=on -qmp tcp:0:4444,server,nowait -spice port=5930,disable-ticketing -global qxl-vga.vram_size=67108864 -vga qxl -device qxl,id=video1,vram_size=67108864,bus=bridge2,addr=0x2 -drive file=/mnt/rhel7cp1.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=bridge2,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=vnet0,vhost=off,fd=3 -device virtio-net-pci,bus=bridge2,addr=0x3,netdev=vnet0,mac=f2:ca:d1:ed:91:71,id=vnic1 -monitor unix:/tmp/mon1,server,nowait 3<>/dev/tap3

2.Migrate guest from src to dst host.

3.After migration, check guest(I ping guest before migration).

Actual results:
1.Guest hangs, and ping failed after migration.
2.After system_reset, guest resumes well.

Expected results:
After migration, guest works well.

Additional info:
Comment 2 Michael S. Tsirkin 2013-07-14 06:41:12 EDT
upstream fix for this bug:
http://patchwork.ozlabs.org/patch/257742/
Comment 3 Michael S. Tsirkin 2013-07-29 05:39:43 EDT
commit e78e9ae4a933504d383703870d491615b0261801
Comment 4 Marcel Apfelbaum 2013-09-10 09:56:51 EDT
Downgraded it to TestOnly because the upstream commit has made it into 1.5.3 (as a3ea885a), and we have that in qemu-kvm-1.5.3-1.el7.
Comment 5 Qunfang Zhang 2013-11-28 01:00:47 EST
Reproduced on qemu-kvm-1.5.1-2.el7.x86_64, and verified pass on qemu-kvm-1.5.3-19.el7.x86_64.

Steps:

1. The same as comment 0. Boot guest with all devices over pci-bridge under pci-bridge.

/usr/libexec/qemu-kvm -M pc -device pci-bridge,id=bridge1,chassis_nr=1 -device pci-bridge,id=bridge2,bus=bridge1,addr=0x2,chassis_nr=1 -cpu Penryn -m 4G -smp 4,sockets=1,cores=4,threads=1 -enable-kvm -nodefaults -nodefconfig -monitor stdio -boot menu=on -qmp tcp:0:4444,server,nowait -vnc :10 -vga std -drive file=/opt/rhel7.0-64-qzhang.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=bridge2,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=vnet0,vhost=off -device virtio-net-pci,bus=bridge2,addr=0x3,netdev=vnet0,mac=f2:ca:d1:ed:91:71,id=vnic1 -monitor unix:/tmp/mon1,server,nowait

2. Migrate guest to another host which shares same storage with this host. 

(qemu) migrate -d tcp:$remote_host_ip:5800

3. Check guest mouse,keyboard,network.

On the old version qemu-kvm-1.5.1-2.el7.x86_64: after migration, can not ping guest ip any more. Input some commands inside guest like "top", "route", guest will hang, the commands do not return. 

On the fixed version qemu-kvm-1.5.3-19.el7.x86_64.rpm: after migration, guest works well. Input some commands inside guest, all could output the expected content. Ping between guest and external host, succeed.

So this bug is fixed.
Comment 6 Ludek Smid 2014-06-13 07:16:08 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.