Bug 983550 - SELinux is preventing /usr/bin/python2.7 from using the 'execmem' accesses on a process.
SELinux is preventing /usr/bin/python2.7 from using the 'execmem' accesses on...
Status: CLOSED DUPLICATE of bug 915118
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d90df7a58df605d290e72304a76...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 08:56 EDT by leigh scott
Modified: 2013-07-11 08:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 08:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leigh scott 2013-07-11 08:56:08 EDT
Description of problem:
Tried to run sealert
SELinux is preventing /usr/bin/python2.7 from using the 'execmem' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that python2.7 should be allowed execmem access on processes labeled setroubleshoot_fixit_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep sealert /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.
                              c1023
Target Context                system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.
                              c1023
Target Objects                 [ process ]
Source                        sealert
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-59.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-1.fc19.x86_64 #1 SMP Sun
                              Jul 7 22:45:17 BST 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-11 13:52:48 BST
Last Seen                     2013-07-11 13:52:48 BST
Local ID                      65fabfe9-4ac9-4afc-8335-8647d4bd18a4

Raw Audit Messages
type=AVC msg=audit(1373547168.393:654): avc:  denied  { execmem } for  pid=6757 comm="sealert" scontext=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 tcontext=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1373547168.393:654): arch=x86_64 syscall=mmap success=yes exit=261664636928 a0=3cec6d8000 a1=40000 a2=7 a3=812 items=0 ppid=6756 pid=6757 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=sealert exe=/usr/bin/python2.7 subj=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 key=(null)

Hash: sealert,setroubleshoot_fixit_t,setroubleshoot_fixit_t,process,execmem

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.0-1.fc19.x86_64
type:           libreport

Potential duplicate: bug 915118
Comment 1 leigh scott 2013-07-11 08:58:56 EDT

*** This bug has been marked as a duplicate of bug 915118 ***

Note You need to log in before you can comment on or make changes to this bug.