Bug 983558 - semanage login delete should not require seuser
semanage login delete should not require seuser
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
Ondrej Moriš
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 09:22 EDT by Miroslav Vadkerti
Modified: 2015-11-03 05:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
semnage-login.patch (874 bytes, patch)
2013-07-11 09:35 EDT, Miroslav Grepl
no flags Details | Diff

  None (edit)
Description Miroslav Vadkerti 2013-07-11 09:22:01 EDT
Description of problem:
# semanage login -d test
seuser option is needed for delete

Version-Release number of selected component (if applicable):
policycoreutils-2.1.14-60.el7

How reproducible:
100%

Steps to Reproduce:
1. semanage login -d test

Actual results:
seuser option is needed for delete

Expected results:
user deleted (no sesuser option needed)

Additional info:
Comment 1 Miroslav Grepl 2013-07-11 09:35:42 EDT
Created attachment 772222 [details]
semnage-login.patch
Comment 4 Milos Malik 2013-07-11 10:52:16 EDT
The semanage tool belongs to policycoreutils component.
Comment 5 Daniel Walsh 2013-07-11 15:05:01 EDT
Fixed in policycoreutils-2.1.14-63.el7.src.rpm
Comment 6 Ondrej Moriš 2013-08-23 10:48:07 EDT
Successfully verified.

# semanage login -l

Login Name           SELinux User         MLS/MCS Range        Service

__default__          unconfined_u         SystemLow-SystemHigh *
root                 unconfined_u         SystemLow-SystemHigh *
system_u             system_u             SystemLow-SystemHigh *
[root@cc-toe3 audit-remote]# semanage login -a test -s system_u
[root@cc-toe3 audit-remote]# semanage login -l

Login Name           SELinux User         MLS/MCS Range        Service

__default__          unconfined_u         SystemLow-SystemHigh *
root                 unconfined_u         SystemLow-SystemHigh *
system_u             system_u             SystemLow-SystemHigh *
test                 system_u             SystemLow            *
[root@cc-toe3 audit-remote]# semanage login -d test
[root@cc-toe3 audit-remote]# semanage login -l

Login Name           SELinux User         MLS/MCS Range        Service

__default__          unconfined_u         SystemLow-SystemHigh *
root                 unconfined_u         SystemLow-SystemHigh *
system_u             system_u             SystemLow-SystemHigh *
[root@cc-toe3 audit-remote]# rpm -q policycoreutils
policycoreutils-2.1.14-75.el7.x86_64
Comment 7 Ludek Smid 2014-06-13 07:50:57 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.