Bug 983701 - X segfaults when running mozilla products (firefox, thunderbird)
X segfaults when running mozilla products (firefox, thunderbird)
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 14:06 EDT by kevin martin
Modified: 2015-06-29 08:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:04:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log with stack trace (28.48 KB, text/plain)
2013-07-11 14:06 EDT, kevin martin
no flags Details
thunderbird strace (137.50 KB, text/x-log)
2013-07-11 14:07 EDT, kevin martin
no flags Details
startx log showing the state of X in the crash that wasn't quite a crash. (5.04 KB, text/x-log)
2013-07-11 16:10 EDT, kevin martin
no flags Details
xorg log during the crash that wasn't quite a crash. (27.35 KB, text/x-log)
2013-07-11 16:11 EDT, kevin martin
no flags Details
dmesg after the crash that wasn't quite a crash of X (105.86 KB, text/x-log)
2013-07-11 16:11 EDT, kevin martin
no flags Details

  None (edit)
Description kevin martin 2013-07-11 14:06:51 EDT
Created attachment 772354 [details]
Xorg log with stack trace

Description of problem:
Running the latest updates for everything rawhide; when I try to start Firefox or Thunderbird, X crashes with a segfault.


Version-Release number of selected component (if applicable):
X.Org X Server 1.14.2
Release Date: 2013-06-25
[  4207.937] X Protocol Version 11, Revision 0


How reproducible:
Happens everytime

Steps to Reproduce:
1.run X
2.try to start firefox or thunderbird
3.watch it crash

Actual results:
X crashes

Expected results:
X runs

Additional info:

I've attached the Xorg.0.log file that I saved showing the segfault.  FWIW, google-chrome does not cause this crash.  I've also attached an strace of my thunderbird run where X crashed.
Comment 1 kevin martin 2013-07-11 14:07:39 EDT
Created attachment 772355 [details]
thunderbird strace
Comment 2 kevin martin 2013-07-11 14:08:49 EDT
Needless to say this makes my environment non-optimal as I can't retrieve email or browse the web with my preferred applications.
Comment 3 kevin martin 2013-07-11 14:59:44 EDT
Disabling module GLX in xorg.conf allows me to run thunderbird and firefox again.  Interestingly enough, gthumb won't run now (gthumb also caused the X crash with GLX enabled but won't run now with the error):

(gthumb:21011): GModule-CRITICAL **: g_module_close: assertion 'module->ref_count > 0' failed

** (gthumb:21011): CRITICAL **: Failed to parse arguments: Failed to connected to any renderer due to constraints

So two steps forward, one back, but it's progress of a sort.
Comment 4 kevin martin 2013-07-11 16:09:40 EDT
Hmm, interesting.  So it appears that glx is *not* disabled after all:

[  9927.958] (WW) "glx" will not be loaded unless you've specified it to be loaded elsewhere.
[  9927.958] (II) "glx" will be loaded even though the default is to disable it.


But if I don't disable it then I can't run firefox and thunderbird.  Also, I have an interesting "crash" take place where the X windows went away but X was still running, my applications were still running, but I couldn't get back to an X windows.  The console in which I ran the startx would give me gibberish when I tried to type anything but other consoles worked ok.  I've attached startx and xorg.0.log files showing the state at the time of the crash that wasn't quite a crash.
Comment 5 kevin martin 2013-07-11 16:10:39 EDT
Created attachment 772403 [details]
startx log showing the state of X in the crash that wasn't quite a crash.
Comment 6 kevin martin 2013-07-11 16:11:16 EDT
Created attachment 772405 [details]
xorg log during the crash that wasn't quite a crash.
Comment 7 kevin martin 2013-07-11 16:11:45 EDT
Created attachment 772406 [details]
dmesg after the crash that wasn't quite a crash of X
Comment 8 Fedora End Of Life 2013-09-16 10:29:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 9 Fedora End Of Life 2015-05-29 05:10:31 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 edwardp 2015-05-31 15:57:35 EDT
I was able to resolve this in Fedora 21 by disabling the GLX driver. In /usr/lib64/xorg/modules/extensions/ I renamed libglx.so to libglx.so.old and rebooted. 

Firefox, Thunderbird and SeaMonkey then successfully launched and ran.

The video is:

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 2a6c
	Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
	Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
	[virtual] Expansion ROM at c0000000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nouveau
	Kernel modules: nouveau
Comment 11 Fedora End Of Life 2015-06-29 08:04:29 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.