Bug 983716 - java.lang.reflect.InvocationTargetException removing a server from cluster [NEEDINFO]
java.lang.reflect.InvocationTargetException removing a server from cluster
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Dustin Tsang
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 14:56 EDT by Dustin Tsang
Modified: 2016-04-18 06:06 EDT (History)
11 users (show)

See Also:
Fixed In Version: rhsc-cb7
Doc Type: Bug Fix
Doc Text:
Previously, removing a server from cluster was failing and an error message was displayed. Now, the server is removed successfully and an appropriate message is displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:33:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sharne: needinfo? (kmayilsa)


Attachments (Terms of Use)
engine.log excerpt (83.89 KB, text/plain)
2013-07-11 14:56 EDT, Dustin Tsang
no flags Details
vdsm log (10.34 MB, text/x-log)
2013-07-11 14:57 EDT, Dustin Tsang
no flags Details
engine logs (17.10 MB, text/plain)
2013-08-01 00:49 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Dustin Tsang 2013-07-11 14:56:32 EDT
Created attachment 772381 [details]
engine.log excerpt

Description of problem:

When removing a server from cluster, an exception dialog is received instead of the confirmation dialog.


attaching engine.log: error occurs at 2013/7/11 15:52 ist

vdsm.log stops logging after the time of the error


Version-Release number of selected component (if applicable):
rhsc-bb5
rhs20130711n.iso

How reproducible:

not easily reproducible 

Steps to Reproduce:
1. put the server in maintenance
2. click remove


Actual results:
dialog displays with exception "Error while executing action: A Request to the ServerFailed: java.lang.reflect.InvocationtargetException"

Expected results:
confirmation dialog displays


Additional info:
Comment 1 Dustin Tsang 2013-07-11 14:57:48 EDT
Created attachment 772382 [details]
vdsm log
Comment 4 Dustin Tsang 2013-07-31 07:50:09 EDT
occurs intermittently
Comment 5 Shruti Sampat 2013-08-01 00:46:42 EDT
Saw this issue again. Attaching engine logs.
Comment 6 Shruti Sampat 2013-08-01 00:49:45 EDT
Created attachment 781440 [details]
engine logs
Comment 7 Dustin Tsang 2013-08-08 16:38:10 EDT
this is occurring very frequently in the automation suite, causing multiple failures during the automation run.
Comment 8 Kanagaraj 2013-11-12 12:54:59 EST
Dustin,
 
 I see a GWT serialization problem which caused this issue got fixed recently.
 
Are you seeing this issue in CB builds? Can you please check it out and let me know.  

If you are still encountering this problem, please attach both engine.log and server.log
Comment 9 Dustin Tsang 2013-11-13 10:20:26 EST
acknowledged...moving to ON_QA. Will re-open based upon our findings.
Comment 10 Matt Mahoney 2013-11-20 14:39:57 EST
Validated in cb7/b8. Have not seen this issue, and will reopen if it appears again.
Comment 11 Shalaka 2014-01-21 02:05:41 EST
Please review the edited DocText and signoff.
Comment 12 Kanagaraj 2014-01-21 02:07:47 EST
" an appropriate message is displayed" is not required
Comment 14 errata-xmlrpc 2014-02-25 02:33:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.