Bug 983897 - jboss brms does not log messages to server log
jboss brms does not log messages to server log
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Kris Verlaenen
Radovan Synek
:
: 1013212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 04:35 EDT by Radovan Synek
Modified: 2014-08-06 16:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-07-12 04:35:51 EDT
JBoss-brms logging does not work likely because of WEB-INF/classes/log4j.xml configuration file. This is probably the same issue as bug 973136.

After deleting the log4j.xml file I can see jboss-brms messages in server log.

Version-Release number of selected component (if applicable):
DR6
Comment 1 Kris Verlaenen 2013-07-12 18:54:39 EDT
This has been fixed in Beta5 already, file was removed.
Comment 2 Radovan Synek 2013-09-03 11:01:52 EDT
BRMS business-central still doesn't log messages to server.log

Take a look at business-central.war/WEB-INF/classes:
for BPMS: there is logback.xml => logging works
for BRMS: there is both logback.xml and log4j.xml => logging doesn't work

I believe the log4j.xml shouldn't be there.
Comment 4 Kris Verlaenen 2013-10-04 08:37:55 EDT
*** Bug 1013212 has been marked as a duplicate of this bug. ***
Comment 8 Radovan Synek 2013-10-15 04:50:36 EDT
Verified on BRMS-6.0.0.ER4
Comment 9 Radovan Synek 2014-03-18 12:30:32 EDT
qe_test_coverage: absence of logging is very obvious, no need for additional test

Note You need to log in before you can comment on or make changes to this bug.