Bug 983928 - Categories editor not accessible
Categories editor not accessible
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Toni Rikkola
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 05:59 EDT by Jiri Locker
Modified: 2014-12-05 06:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2013-07-12 05:59:52 EDT
Description of problem:
The new Project Explorer doesn't display categories.xml. There is no other way to access categories editor.

Version-Release number of selected component (if applicable):
DR6
Comment 1 manstis 2013-09-05 04:40:52 EDT
Alexandre, could you please add some way to access the categories editor from perhaps the Tools menu (like Data Modeller and Project Editor). Thanks.
Comment 2 Jiri Locker 2013-09-05 05:19:05 EDT
Micheal, Alexandre, I was surprised when categories disappeared from project explorer in on of the new builds several weeks back. But, there is a question: Are they needed for this release? I haven't come across any use case in the workbench (category based rule inheritance has been replaced, no role-to-category permission mapping like in 5.x), am I missing something? If there really is no use for categories there is no point in adding tools for it, wdyt?
Comment 3 Edson Tirelli 2013-09-30 18:00:37 EDT
Michael, Porcelli, please see Jiri's comment above. Do we still need this?
Comment 7 Toni Rikkola 2013-10-16 02:40:52 EDT
(In reply to Jiri Locker from comment #2)
> Micheal, Alexandre, I was surprised when categories disappeared from project
> explorer in on of the new builds several weeks back. But, there is a
> question: Are they needed for this release? I haven't come across any use
> case in the workbench (category based rule inheritance has been replaced, no
> role-to-category permission mapping like in 5.x), am I missing something? If
> there really is no use for categories there is no point in adding tools for
> it, wdyt?

The rule inheritance and permission mappings based on categories will be dropped.

However categories offers another way to group rules and on a huge rule bases they make finding rules easier. The other way to group rules is using packages. So we have "org.mypackage" vs. "Validation rules" where the second way is more readable. 

If this is really needed for the next release? Since we do not offer a screen that lets the user to browse based on categories, not really. Still I did it since it was a 5 minute change. Easy to roll back if we decide to drop it for now.

In the future I can see that we will add group editing options for categories. For example when browsing by categories the user could group change a status for all the files in a category. (Status will not be on the next release, it is on our todo list)
Comment 8 Toni Rikkola 2013-11-05 08:22:35 EST
One more commit for this. The old one did not cover kie-wb-distribution wars.

Note You need to log in before you can comment on or make changes to this bug.