This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983967 - 3.7.4. 'Install Patches in RPM form' Needs several changes
3.7.4. 'Install Patches in RPM form' Needs several changes
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: GA
: ---
Assigned To: Lucas Costi
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 08:13 EDT by Pavel Janousek
Modified: 2014-08-14 11:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 6895, Installation Guide-6.1-2 Build Date: 11-07-2013 14:10:24 Topic ID: 13444-444128 [Specified]
Last Closed: 2013-12-15 11:22:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Janousek 2013-07-12 08:13:19 EDT
Title: Install Patches in RPM form

Describe the issue:


Suggestions for improvement:
1. Documentation is for EAP6, there aren't several product of EAP6, so I don't like to read that patch ZIP is distributed for all product and RPM only for subset of them.

2. It isn't true bug fixes aren't distributed in RPM. This policy was in the past, but right now, it depends on triage by PM and GSS. It is true not every OneOff ZIP patch is distributed by RPM as well, but RPM way isn't limited to secitury fixes only.

3. Procedure 3.14. I'm not native speaker, moreover erratum/errata comes from Latina, but as far as I know, erratum is one concrete fix, so you can't mention 'Erratum' as 'list of resolved flaws' because in this case it becomes 'Errata'. I prefer to use 'Errata' in every a such places. Basically - we can't distribute an Erratum because we need to cover at least both of RHEL (5 and 6), so there are at least 2 erratums always distributed as errata.

4. Don't mention any other update command or way because 'yum update' is only the one supported way how to apply patches in RPM installation. (affected are: a) first para in procedure 3.14 and step 4)


It should be also highlighted that in RPM customer get every OneOffs after yum update always (-> 'yum update' acts as cumulative update way), but in ZIP particular ZIP contains only particular fix -> in ZIP patch isn't cumulative usually.
Comment 1 Pavel Janousek 2013-07-25 09:39:45 EDT
Step 3 needs rephrase as well because customer should have his machine subscribed to JBoss EAP channel already, so it isn't needed to manually download any RPM package.
Comment 5 Lucas Costi 2013-10-23 00:55:58 EDT
>1. Documentation is for EAP6, there aren't several product of EAP6, so I don't like to read that patch ZIP is distributed for all product and RPM only for subset of them.
--- This topic has been originally written for documentation reuse across multiple JBoss products, which is why it refers "JBoss product" rather than specificially JBoss EAP

>2. It isn't true bug fixes aren't distributed in RPM. This policy was in the past, but right now, it depends on triage by PM and GSS. It is true not every OneOff ZIP patch is distributed by RPM as well, but RPM way isn't limited to secitury fixes only.
--- I have removed that sentence.

>3. Procedure 3.14. I'm not native speaker, moreover erratum/errata comes from Latina, but as far as I know, erratum is one concrete fix, so you can't mention 'Erratum' as 'list of resolved flaws' because in this case it becomes 'Errata'. I prefer to use 'Errata' in every a such places. Basically - we can't distribute an Erratum because we need to cover at least both of RHEL (5 and 6), so there are at least 2 erratums always distributed as errata.
--- Fixed.

>4. Don't mention any other update command or way because 'yum update' is only the one supported way how to apply patches in RPM installation. (affected are: a) first para in procedure 3.14 and step 4)
--- Fixed.

>It should be also highlighted that in RPM customer get every OneOffs after yum update always (-> 'yum update' acts as cumulative update way), but in ZIP particular ZIP contains only particular fix -> in ZIP patch isn't cumulative usually.
--- A note has been added to the yum update step

Note that in the latest build of the 6.2 Installation Guide, this topic is now 4.6.4

The changes will be reflected in the next document build, and the status will be changed to ON_QA when it is ready for review.
Comment 6 Lucas Costi 2013-10-23 00:57:02 EDT
The above changes are in topic 13444, revision 548478.
Comment 8 Pavel Janousek 2013-10-25 08:14:15 EDT
Looks good, fixed.

Note You need to log in before you can comment on or make changes to this bug.