Bug 983972 - [abrt] gnome-settings-daemon-3.6.3-2.el7: g_logv: Process /usr/libexec/gnome-settings-daemon was killed by signal 5 (SIGTRAP)
[abrt] gnome-settings-daemon-3.6.3-2.el7: g_logv: Process /usr/libexec/gnome-...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rui Matos
Desktop QE
abrt_hash:e4fa2f35029de935e4f91495f56...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 08:25 EDT by Jiri Moskovcak
Modified: 2017-07-03 11:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 09:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.23 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: cgroup (131 bytes, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: core_backtrace (1.94 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: dso_list (12.25 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: environ (1.23 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: maps (63.72 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: open_fds (2.16 KB, text/plain)
2013-07-12 08:25 EDT, Jiri Moskovcak
no flags Details
File: proc_pid_status (1.05 KB, text/plain)
2013-07-12 08:26 EDT, Jiri Moskovcak
no flags Details
File: var_log_messages (704 bytes, text/plain)
2013-07-12 08:26 EDT, Jiri Moskovcak
no flags Details

  None (edit)
Description Jiri Moskovcak 2013-07-12 08:25:31 EDT
Description of problem:


Version-Release number of selected component:
gnome-settings-daemon-3.6.3-2.el7

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-settings-daemon
crash_function: g_logv
executable:     /usr/libexec/gnome-settings-daemon
kernel:         3.9.0-0.rc6.51.el7.x86_64
runlevel:       unknown
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_settings_schema_get_value at /lib64/libgio-2.0.so.0
 #3 g_settings_schema_key_init at /lib64/libgio-2.0.so.0
 #4 g_settings_get_value at /lib64/libgio-2.0.so.0
 #5 g_settings_get_boolean at /lib64/libgio-2.0.so.0
 #6 gnome_bg_load_from_preferences at /lib64/libgnome-desktop-3.so.4
 #7 gsd_background_manager_start at /usr/lib64/gnome-settings-daemon-3.0/libbackground.so
 #8 impl_activate at /usr/lib64/gnome-settings-daemon-3.0/libbackground.so
 #9 gnome_settings_plugin_info_activate
 #10 maybe_activate_plugin
 #11 g_slist_foreach at /lib64/libglib-2.0.so.0
Comment 1 Jiri Moskovcak 2013-07-12 08:25:37 EDT
Created attachment 772659 [details]
File: backtrace
Comment 2 Jiri Moskovcak 2013-07-12 08:25:40 EDT
Created attachment 772660 [details]
File: cgroup
Comment 3 Jiri Moskovcak 2013-07-12 08:25:43 EDT
Created attachment 772661 [details]
File: core_backtrace
Comment 4 Jiri Moskovcak 2013-07-12 08:25:46 EDT
Created attachment 772662 [details]
File: dso_list
Comment 5 Jiri Moskovcak 2013-07-12 08:25:49 EDT
Created attachment 772663 [details]
File: environ
Comment 6 Jiri Moskovcak 2013-07-12 08:25:52 EDT
Created attachment 772664 [details]
File: limits
Comment 7 Jiri Moskovcak 2013-07-12 08:25:55 EDT
Created attachment 772665 [details]
File: maps
Comment 8 Jiri Moskovcak 2013-07-12 08:25:58 EDT
Created attachment 772666 [details]
File: open_fds
Comment 9 Jiri Moskovcak 2013-07-12 08:26:01 EDT
Created attachment 772667 [details]
File: proc_pid_status
Comment 10 Jiri Moskovcak 2013-07-12 08:26:03 EDT
Created attachment 772668 [details]
File: var_log_messages
Comment 12 Bastien Nocera 2013-11-22 09:11:52 EST
b4ce4e16275347edd3b3b738f5f2f8727fc6e0e4 0xaf69b g_settings_get_boolean /lib64/libgio-2.0.so.0 9a3f88366acb159f486c98c8858b211a1005afdc
8ad9b50c18cba585e1f53a0bc9bcc9ca1bdf2982 0x1394f gnome_bg_load_from_preferences /lib64/libgnome-desktop-3.so.4 f82a48f4a56962b3423a97a3cbe361f46868f600

There's no calls to g_settings_get_boolean in gnome_bg_load_from_preferences in more recent versions of gnome-desktop.

In GNOME 3.6 we did have [1]:
	bg->is_enabled = g_settings_get_boolean (settings, BG_KEY_DRAW_BACKGROUND);
which is likely the cause of the crash.

As this won't happen with the GNOME 3.8 in RHEL7, I'll close this.

[1]: https://git.gnome.org/browse/gnome-desktop/tree/libgnome-desktop/gnome-bg.c?h=gnome-3-6#n340

Note You need to log in before you can comment on or make changes to this bug.