Bug 983989 - While configuration host networks: IOError: [Errno 2] No such file or directory: '/sys/class/net/bonding_masters'
While configuration host networks: IOError: [Errno 2] No such file or directo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
medium Severity high
: ---
: 3.3.0
Assigned To: Assaf Muller
network
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-07-12 09:21 EDT by Martin Pavlik
Modified: 2016-02-10 14:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:28:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amuller: needinfo-


Attachments (Terms of Use)
log_collector (8.48 MB, application/x-xz)
2013-07-12 09:21 EDT, Martin Pavlik
no flags Details
screenshot 1 (208.18 KB, image/png)
2013-07-12 09:22 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-07-12 09:21:37 EDT
Created attachment 772696 [details]
log_collector

Description of problem:
Trying to create bond on host via webadmin -> Setup Hosts Networks 
returns following error:
Error while executing action Setup Networks: Unexpected exception (see screenshot)
error messages from logs are bellow

this probably happens because "bond" interfaces are not created on host when host is added to setup any more


Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.3.0-0.2.master.20130710172219.git240a5ed.fc18 
vdsm-4.11.0-123.gitdd3f6ca.fc18

How reproducible:
100%

Steps to Reproduce:
1. add new host to setup (make sure it does not have any bond* interfaces defined)
2. Hosts -> your host -> network interfaces -> setup host networks
3. create bond (e.g. bond1), no need to attach network -> click ok -> click OK

Actual results:
cannot create bond

Expected results:
bond should be created

Additional info:

engine.log
013-07-12 14:50:54,781 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp--127.0.0.1-8702-9) FINISH, SetupNetworksVDSCommand, log id: 1ad97e1d
2013-07-12 14:50:55,288 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp--127.0.0.1-8702-9) Failed in SetupNetworksVDS method
2013-07-12 14:50:55,293 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp--127.0.0.1-8702-9) Error code unexpected and error message VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = Unexpected exception
2013-07-12 14:50:55,299 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp--127.0.0.1-8702-9) org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = Unexpected exception
2013-07-12 14:50:55,304 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp--127.0.0.1-8702-9) Command SetupNetworksVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = Unexpected exception
2013-07-12 14:50:55,306 ERROR [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (ajp--127.0.0.1-8702-9) Command org.ovirt.engine.core.bll.network.host.SetupNetworksCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = Unexpected exception (Failed with VDSM error unexpected and code 16)


vdsm.log
Thread-83::DEBUG::2013-07-12 14:50:54,807::BindingXMLRPC::953::vds::(wrapper) return ping with {'status': {'message': 'Done', 'code': 0}}
Thread-82::ERROR::2013-07-12 14:50:54,834::BindingXMLRPC::965::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 951, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 400, in setupNetworks
    return api.setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/API.py", line 1238, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 49, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in setupNetworks
  File "/usr/lib64/python2.7/multiprocessing/managers.py", line 773, in _callmethod
    raise convert_to_error(kind, result)
IOError: [Errno 2] No such file or directory: '/sys/class/net/bonding_masters'
Comment 1 Martin Pavlik 2013-07-12 09:22:08 EDT
Created attachment 772697 [details]
screenshot 1
Comment 2 Alon Bar-Lev 2013-07-12 09:31:55 EDT
In 3.3 engine is doing the network setup post host-deploy.
Comment 3 Dan Kenigsberg 2013-07-21 17:51:33 EDT
This should have been fixed by http://gerrit.ovirt.org/16610 which loads the bonding module once vdsm.rpm is installed.

Martin, would you verify that?
Comment 4 Martin Pavlik 2013-07-23 11:25:47 EDT
works in IS6

fresh host after adding to RHEVM

[root@dell-r210ii-06 ~]# lsmod | grep bond
bonding               127331  0 

[root@dell-r210ii-06 ~]# ip a l | grep bond
8: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN 
9: bond4: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN 
10: bond1: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN 
11: bond2: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN 
12: bond3: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN
Comment 5 Charlie 2013-11-27 19:27:52 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:28:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.