This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984060 - [abrt] vim-enhanced-7.3.944-1.fc19: may_core_dump: Process /usr/bin/vim was killed by signal 11 (SIGSEGV)
[abrt] vim-enhanced-7.3.944-1.fc19: may_core_dump: Process /usr/bin/vim was k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
abrt_hash:e66bd318e2d5f9afac9decaca0f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 12:09 EDT by Zdenek Sekera
Modified: 2013-09-10 04:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 04:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.88 KB, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: core_backtrace (833 bytes, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: dso_list (1.57 KB, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: environ (5.14 KB, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: maps (4.88 KB, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: open_fds (135 bytes, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: proc_pid_status (781 bytes, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: var_log_messages (865 bytes, text/plain)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details
File: system_vimrc (1.92 KB, application/octet-stream)
2013-07-12 12:10 EDT, Zdenek Sekera
no flags Details

  None (edit)
Description Zdenek Sekera 2013-07-12 12:09:56 EDT
Description of problem:
Sudden crash of vim, no idea why, have no idea if/how to reproduce it though it happened twice within a short time.

Version-Release number of selected component:
vim-enhanced-7.3.944-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        vim .kshrc
crash_function: may_core_dump
executable:     /usr/bin/vim
kernel:         3.9.9-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 may_core_dump at os_unix.c:3221
 #4 mch_exit at os_unix.c:3187
 #5 getout at main.c:1504
 #6 deathtrap at os_unix.c:1095
 #8 __find_specmb at printf-parse.h:109
 #9 _IO_vfprintf_internal at vfprintf.c:1308
 #10 ___vsprintf_chk at vsprintf_chk.c:85
 #11 ___sprintf_chk at sprintf_chk.c:32
 #12 sprintf at /usr/include/bits/stdio2.h:33
 #13 call_func at eval.c:8416

Potential duplicate: bug 835143
Comment 1 Zdenek Sekera 2013-07-12 12:10:00 EDT
Created attachment 772782 [details]
File: backtrace
Comment 2 Zdenek Sekera 2013-07-12 12:10:02 EDT
Created attachment 772783 [details]
File: cgroup
Comment 3 Zdenek Sekera 2013-07-12 12:10:06 EDT
Created attachment 772784 [details]
File: core_backtrace
Comment 4 Zdenek Sekera 2013-07-12 12:10:09 EDT
Created attachment 772785 [details]
File: dso_list
Comment 5 Zdenek Sekera 2013-07-12 12:10:12 EDT
Created attachment 772786 [details]
File: environ
Comment 6 Zdenek Sekera 2013-07-12 12:10:15 EDT
Created attachment 772787 [details]
File: limits
Comment 7 Zdenek Sekera 2013-07-12 12:10:18 EDT
Created attachment 772788 [details]
File: maps
Comment 8 Zdenek Sekera 2013-07-12 12:10:21 EDT
Created attachment 772789 [details]
File: open_fds
Comment 9 Zdenek Sekera 2013-07-12 12:10:25 EDT
Created attachment 772790 [details]
File: proc_pid_status
Comment 10 Zdenek Sekera 2013-07-12 12:10:28 EDT
Created attachment 772791 [details]
File: var_log_messages
Comment 11 Zdenek Sekera 2013-07-12 12:10:31 EDT
Created attachment 772792 [details]
File: system_vimrc
Comment 12 Martin Povolny 2013-09-03 01:35:16 EDT
I updated my Fedora yesterday and since that update I get SEGV each time I open certain file. 100% reproducible. I can provide access to my system if necessary.

[martin@piskot vmdb]$ rpm -qa | grep vim
vim-enhanced-7.4.0-2.fc19.x86_64
vim-filesystem-7.4.0-2.fc19.x86_64
vim-common-7.4.0-2.fc19.x86_64
vim-minimal-7.4.0-2.fc19.x86_64
Comment 13 Karsten Hopp 2013-09-03 05:42:16 EDT
Does vim-7.4.9-1.fc19 from f19-updates testing fix your issue ?
Comment 14 Martin Povolny 2013-09-03 07:16:52 EDT
I apologize for my limited yum fu, but I cannot see version you indicated even when I enable the updates-testing repo.
Comment 15 Martin Povolny 2013-09-10 01:32:11 EDT
yesterday's update to 7.4.016-1.fc19 resolved the issue for me

[martin@piskot vmdb]$ rpm -qa | grep vim
vim-minimal-7.4.016-1.fc19.x86_64
vim-filesystem-7.4.016-1.fc19.x86_64
vim-common-7.4.016-1.fc19.x86_64
vim-enhanced-7.4.016-1.fc19.x86_64

no more vim segfaults
Comment 16 Karsten Hopp 2013-09-10 04:42:48 EDT
Thanks for the bugreport and for following up with comment #15 !
I'll close this as resolved.

Note You need to log in before you can comment on or make changes to this bug.