Bug 984076 - Improve adding of actors to user tasks
Improve adding of actors to user tasks
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Eclipse Tooling (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ER2
: 6.0.0
Assigned To: Robert (Bob) Brodt
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 12:56 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Svitak 2013-07-12 12:56:38 EDT
There are several issues with actor adding to user tasks, which are not blockers, but are uncomfortable to users.

If I click the green plus button on Actor box of User Task tab, I want to write the actor's name by clicking on grayed text New Actor.

three actions may randomly (?) occur:
- cannot click on New Actor to edit it, keep clicking and nothing happens (I can edit the Script field on the right, but its change does not propagate to the right panel immediately)
- new minimal edit button pops up and I can type actor's name, but cannot see the result, only after reopen of the user task properties window
- can actually edit the name and see immediately the change of actor's name

I have observed another issue - Formal Expression panel may open, but once I select Java or MVEL, I cannot select or return to plain string, which defines the actor. Only delete him and try to add him again.

I think that the editor should behave in a bit more consistent way and propagate changes faster to other related edit fields. Also possibility to add to select 'plain' formal expression besides MVEL and Java.

I use JBDS 6 and BPMN2 Editor 0.2.5.201305082126, runtime None.
Comment 1 Robert (Bob) Brodt 2013-09-06 12:15:53 EDT
It looks like this has been fixed. Please retest with 0.2.7
Comment 2 Marek Baluch 2013-09-08 03:52:52 EDT
Unable to verify fix on current editor because of https://bugs.eclipse.org/bugs/show_bug.cgi?id=416793
Comment 3 Marek Baluch 2013-09-23 12:59:27 EDT
Verified on BPMN2 Editor 0.2.7.201309191900 (JBTIS 4.1.3.Beta3)

Note You need to log in before you can comment on or make changes to this bug.