Bug 984146 - libdvdcss prevents updating glibc
libdvdcss prevents updating glibc
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 22:12 EDT by Peter H. Jones
Modified: 2016-11-24 07:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 23:57:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2013-07-12 22:12:50 EDT
Description of problem:
Can't update glibc with libdvdcss present

Version-Release number of selected component (if applicable):
glibc.x86_64 0:2.16-31.fc18

How reproducible:
Every time

Steps to Reproduce:
1. In a directory containg update rpms, execute
yum update glibc-2.16-33.fc18.x86_64.rpm glibc-common-2.16-33.fc18.x86_64.rpm


Actual results:
Loaded plugins: langpacks, presto, refresh-packagekit, security
Examining glibc-2.16-33.fc18.x86_64.rpm: glibc-2.16-33.fc18.x86_64
Marking glibc-2.16-33.fc18.x86_64.rpm as an update to glibc-2.16-31.fc18.x86_64
Examining glibc-common-2.16-33.fc18.x86_64.rpm: glibc-common-2.16-33.fc18.x86_64
Marking glibc-common-2.16-33.fc18.x86_64.rpm as an update to glibc-common-2.16-31.fc18.x86_64
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.16-31.fc18 will be updated
---> Package glibc.x86_64 0:2.16-33.fc18 will be an update
---> Package glibc-common.x86_64 0:2.16-31.fc18 will be updated
---> Package glibc-common.x86_64 0:2.16-33.fc18 will be an update
--> Processing Dependency: /usr/sbin/ldconfig for package: libdvdcss2-1.2.13-7.fc18.x86_64
--> Finished Dependency Resolution
Error: Package: libdvdcss2-1.2.13-7.fc18.x86_64 (@/libdvdcss2-1.2.13-7.fc18.x86_64)
           Requires: /usr/sbin/ldconfig
           Removing: glibc-2.16-31.fc18.x86_64 (@/glibc-2.16-31.fc18.x86_64)
               Not found
           Updated By: glibc-2.16-33.fc18.x86_64 (/glibc-2.16-33.fc18.x86_64)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Update should proceed normally.

Additional info:
I can work around the problem by temporarily removing and reinstalling libdvdcss and libdvdcss2 (from atrpms repo).
Comment 1 Carlos O'Donell 2013-07-17 23:57:03 EDT
My expectation is that when glibc completes the /usr transition for all the installed files that this error should go away. The reason I say this is because glibc provides /sbin/ldconfig *not* /usr/sbin/ldconfig, and libdvdcss2 should therefore depend on /sbin/dconfig *not* /usr/sbin/ldconfig. I fully agree that glibc should get updated to install into /usr, at which point the problem goes away. We are working on it.

Given that libdvdcss2 is not provided by Fedora I'm marking this particular issue as CLOSED/WONTFIX.
Comment 2 Peter H. Jones 2013-09-03 22:10:39 EDT
Saw this bug while updating to glibc-2.17-14 in F19. Bumping version accordingly.
Comment 3 Peter H. Jones 2014-02-02 21:39:50 EST
Still in FC20. Will bump version.

yum update glibc gives:
"Loaded plugins: changelog, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.18-11.fc20 will be updated
--> Processing Dependency: glibc = 2.18-11.fc20 for package: glibc-devel-2.18-11.fc20.x86_64
--> Processing Dependency: glibc = 2.18-11.fc20 for package: glibc-headers-2.18-11.fc20.x86_64
--> Processing Dependency: glibc = 2.18-11.fc20 for package: glibc-common-2.18-11.fc20.x86_64
---> Package glibc.x86_64 0:2.18-12.fc20 will be an update
--> Running transaction check
---> Package glibc-common.x86_64 0:2.18-11.fc20 will be updated
---> Package glibc-common.x86_64 0:2.18-12.fc20 will be an update
---> Package glibc-devel.x86_64 0:2.18-11.fc20 will be updated
---> Package glibc-devel.x86_64 0:2.18-12.fc20 will be an update
---> Package glibc-headers.x86_64 0:2.18-11.fc20 will be updated
---> Package glibc-headers.x86_64 0:2.18-12.fc20 will be an update
--> Processing Dependency: /usr/sbin/ldconfig for package: libdvdcss2-1.2.13-7.fc20.x86_64
--> Finished Dependency Resolution
Error: Package: libdvdcss2-1.2.13-7.fc20.x86_64 (@/libdvdcss2-1.2.13-7.fc20.x86_64)
           Requires: /usr/sbin/ldconfig
           Removing: glibc-2.18-11.fc20.x86_64 (@anaconda)
               Not found
           Updated By: glibc-2.18-12.fc20.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
"

Note You need to log in before you can comment on or make changes to this bug.